Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #19652

    Love the theme! However none of the pages or posts have any option for comments.

    I’ve already checked “discussions” and checked everything to make sure nothing interfered.

    I’ve disabled all plugins to do with comments.

    I’ve read previous posts in the forums but cannot find a solution.

    The only way to add a comment is for me to be logged in and edit the post and add a comment beneath the post on edit page.

    I did not change any of the .php or add additional css.

    I’ve tried it on responsive layout and fixed and the results are always the same.

    I do have bbpress on the site but as far as I know that should not interfere with the comments.

    Please let me know what I can do to fix this!

    Thanks :)

    #104461

    Hi millsteacherscholars,

    Try to check Settings > Discussion and make sure Users must be registered and logged in to comment is unchecked.

    Regards,

    Ismael

    #104462

    I have the same problem, and addressed this already in the forum.

    “Users must be registered and logged in to comment” is unchecked!

    #104463

    Hi All,

    Just a note is that comments aren’t able to work on any page that uses a template builder template. They can only work on regular pages or posts.

    If you have a regular post or page with the comments turned on but are not showing up, can you link it here so we can inspect it live?

    Regards,

    Devin

    #104464

    I’m having the same problem in a simple News page. please see here http://www.luvhoodparis.com/news

    #104465

    Hi luvhood,

    As far as I know that kind of a page isn’t able to have a comment section. Generally, anything that is a feed of other posts/pages/categories/tags etc isn’t considered a page but just an aggregate of other posts or pages.

    Logically, from the point of view of wordpress a page with a loop in it wouldn’t be getting responded to because its displaying pieces of other posts (where comments would be shown).

    Regards,

    Devin

    #104466

    Hi, I understand what you’re saying, however my confusion is now how to make this work like a normal blog. I mean, our blog posts all feed to the News Page, but how do you get each post to link off into its own individual post? We need to be able to allow comments.

    #104467

    Hi luvhood,

    I think there is something wrong with your installation. Do you have any plugins installed? Try to re-install the theme. When you create a page and assign it as your Blog page on Theme Options, all posts should be individually linked to itself by default. In your case, all posts are link to the news page. I’m not sure how this happened.

    Regards,

    Ismael

    #104468

    Hello there,

    I have exactly the same problem as the person who started this thread. I’ve tried everything she describes also. So here’s the situation.

    * none of the pages or posts have any option for comments. I would need the comment field to show up especially on the blog page (named “Blogi” on my site)

    * I’ve already checked “discussions” and checked everything to make sure nothing interfered.

    * I’ve disabled all plugins to do with comments.

    * I’ve read previous posts in the forums but cannot find a solution.

    * “Users must be registered and logged in to comment” is unchecked

    * Allow comments on the page is checked

    Please advice what to do, I’m really stuck here.

    Thank you very much for you help in advance.

    Regards,

    Mari

    #104469

    Hi,

    Assuming you’re not using the Advance Layout Editor, you need to edit page.php to show comment fields on Pages. Find this code:

    $avia_config['size'] = avia_layout_class( 'main' , false) == 'entry_without_sidebar' ? '' : 'entry_with_sidebar';
    get_template_part( 'includes/loop', 'page' );

    Below, add the comment code.

    //wordpress function that loads the comments template "comments.php"
    comments_template( '/includes/comments.php');

    Regards,

    Ismael

    #104470

    Thank you for your reply. I tried this but it did not do anything. I can get the comment field to show up on the blog page when I click on the “# comments” link on top of the post. But I would like to have the comment field to show up automatically at the end of each post.

    Any more advice what to do?

    Regards,

    Mari

    #104471

    Hi Mari,

    Comments on individual posts is on by default. There is nothing from the theme that needs to be changed for you to have the comments on single posts. Eg http://www.kriesi.at/themes/enfold/2012/12/12/lorem-ipsum-dolor-sit-amet-consectetuer-adipiscing-elit-aenean-commodo-ligula-eget-dolor-aenean-massa/

    Have you modified the single.php at all? Can you link us to one of your single blog pages so we can inspect it and maybe see what is happening?

    Regards,

    Devin

    #162872

    My bad! :) I only now realized that you need to klick the post headline to “open” the post and there you have the comment field! It was not that intuitive thing to do when you have only one post but now when there is several it seems more logical to do so.

    Thank you for your great support. I love the theme!

    Br,
    Mari

    #163249

    Glad we could help. Let us know if you have any other questions or issues :)

    Regards,
    Josue

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Comments do not show up on posts or pages’ is closed to new replies.