Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #25494

    Loving the Eunoia theme – thank you! One problem I’ve got though is that the comments don’t display eg. http://www.selinabarker.com/the-power-of-chatting/

    Spammers seem to be finding a way to leave comments with no problem because I get spam every day appearing in the comment moderation area but no comment box on the site itself so that non spammers can leave messages! So I then added disqus but that doesn’t appear either. What could the problem be?

    #127171

    Hi,

    Edit your post, look fo Screen Options > Discussions. Enable “Allow Comments”.

    You can enable the comments entirely on Settings > Discussions > Default article settings.

    Regards,

    Ismael

    #127172

    I’ve done all that and still no comments. Could it be because I use a specially made template for my blog posts? Or are there any widgets that wipe out comments? I use Shareaholic – has that been known to cause problems. it’s so weird that they don’t appear and yet I’m inundated with spam comments.

    #127173

    Hi selinab,

    If your post template doesn’t actually include the php call for comments to show up as in the default single.php file from the theme then they won’t be included. Eg:

    <div class='entry commententry'>
    <?php comments_template(); ?>
    </div>

    Regards,

    Devin

    #127174

    Ah thank you, OK, that explains it. But I wouldn’t know how to get into all that single.php file stuff. If I use the global default page the comments DO show up, but what I wanted to get rid of was the blog title (which is why I made a different template) – is there an easy way to do that? This is what I’m talking about: http://www.selinabarker.com/what-turns-you-on-30th-july-london-workshop/

    I don’t want “Blog – Latest News” appearing at the top. Thanks for your help.

    #127175

    I just noticed you said you have Eunoia. This was posted in the Display theme forums originally so I’ve moved it to the proper forum.

    To get rid of that Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #top.single-post .title_container {
    display: none;
    }

    Regards,

    Devin

    #127176

    We use the awesome enfold theme but the comment field is missing. I tried all of above… http://blog.site.easy.de/2013/07/08/archivierung-von-dokumenten-die-informationsdrehscheibe-des-unternehmens/

    #127177

    Hi joerg_schaefer,

    First, update to the most recent 1.7.1 version by re-downloading the theme and then installing it just like you did the first time. Then make sure that the single.php file in your theme files has:

    //wordpress function that loads the comments template "comments.php"
    comments_template( '/includes/comments.php');

    If it does, go to your post and double check that you have the comments turned on. You can also go to your main WordPress Settings for Discussion and make sure its on there as well.

    If you are still unable to get them working at that point just make a new topic and we’ll dig a bit further. This topic has gone in a bit too many directions to easily keep track of whats what so I’m going to close it for now.

    Regards,

    Devin

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Comments don't display on posts’ is closed to new replies.