Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #20700

    Hi

    I have recently purchased Elementia theme – which is Great!!. However, I am unable to get the Contact form to send mails to the id specified. I have gone through the documentation and have changed the email id to the one that I want in the contact.html file. I have also FTP the contact.php and send.php files to the server.

    Once I press the Send button, the page refreshes and shows: Your message has been sent.

    However, the message does not reach the email id I have specified in the contact.html file.

    Can some one help??

    gputhige

    #108725

    Hi gputhige,

    I don’t have the Elementia theme files on hand so I’ve tagged Kriesi to take a look.

    A few things you can try is changing the email address to one hosted on your domain in case your host doesn’t let outgoing mails come from their server without the email being hosted there.

    The next would just be to contact your hosting provider and make sure that the contact.php file will work with them. It should on most but a quick look by them will rule out a server issue :)

    Regards,

    Devin

    #108726

    Thanks Devin

    will try this over the weekend and revert to you if any issues.

    Rgds

    Gp

    #108727

    Hi!

    Just ask if you need help.

    Regards,

    Peter

    #108728

    Most of the times this is caused by your server which is not configured to work with phps sendmail function. You can usually just contact your hosting provider and tell them to activate it.

    If for whatever reason they cant or wont do that I am afraid you have to use an external contact form script that allows sending mails via smtp. Here is a tutorial on the topic: http://email.about.com/od/emailprogrammingtips/qt/PHP_Email_SMTP_Authentication.htm

    #108729

    Hi Kriesi

    We are using Yahoo as the service provider. I tried creating a new mail id from the domain I am hosting the web from, but still the messages would not go through. All other features do work fine with no issues.

    Rgds,

    GP

    #108730

    Hi GP,

    Have you tried contacting the Yahoo to see if they allow the php sendmail function?

    Regards,

    Devin

    #108731

    Yes Devin

    I have written to them and expecting a response soon. However, I was wondering if anyone else has any experience of php working on a yahoo site.

    Rgds

    Gp

    #108732

    Hi GP,

    I found this Q&A from Yahoo Small Business on the issue: http://help.yahoo.com/l/us/yahoo/smallbusiness/webhosting/php/php-28.html

    Regards,

    Devin

    #108733

    Thanks Devin

    really appreciate the quick and dedicated support from you all. Your response was faster than Yahoo – will work on this and revert.

    Once again great support… Glad I picked up template from your site.

    Rgds

    GP

    #108734

    Hopefully that helps get the server set up to allow for easy mail sending.

    Regards,

    Devin

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Contact Form in Elementia not sending mails’ is closed to new replies.