Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11159

    Hey there,

    Love the theme, but I’ve run into an issue that I’m having trouble solving. I’ve set my contact form up, but for some reason the page displays my portfolio items instead of the contact form fields. I’ve tried attaching the contact form to new pages (making sure no template was selected) without any luck. I also tried disabling all plugins to see if it might make a difference, but I’ve had no luck. Any other suggestions for me to try? Not having a contact form on my site isn’t an option for me.

    My site is located at http://www.robertswoodcrafts.com, and the contact page is current pointing to robertswoodcrafts.com/contact

    Thanks for your help!

    Dustin

    #70788

    I noticed I was running an out-of-date version of the theme (1.2.1), so I removed 1.2.1 and installed 1.3. Unfortunately my contact page is still displaying my portfolio items instead of the contact form.

    I also tried moving the portfolio entries and the portfolio page itself into draft. No luck; the contact page just displayed the “Nothing found” message.

    I’m really at a loss here…

    #70789

    Hey,

    kindly check if you’ve created a Page called Contact (it doesn’t matter what the page is called but it makes things clear).

    Have you then selected it as your contact page in the Propulsion > Theme Options > Contact?

    And have you checked Appearance > Menus if the Contact link actually links to the page you’ve created?

    Let us know if all of this is set but it still doesn’t function as expected.

    Cheers,

    Chris

    #70790

    Hi Chris,

    I’ve created a page named “Contact”, published the page, and pointed the Contact form to that page in Propulsion’s Theme Options. The menu link also points to the contact page I’ve created. The contact page uses the default template, no layout is selected, and I have not entered any text or code into the body of the page, nor have I uploaded any images/created a slideshow for that page.

    For what it’s worth, I also tried creating a new page named “Email” and setting Propulsion’s contact & the menu link to that page, but it too displayed the portfolio items instead of the contact form.

    Thanks,

    Dustin

    #70791

    Found it!

    Under the Portfolio section in Propulsion’s Theme Options, the group of options for the Portfolio (beginning with “Which categories should be used for the portfolio?” and ending with “Portfolio Pagination”) appeared 4 times. While none of them were set to display on the contact page, I guess the fact that the options appeared multiple times caused some problems. I deleted the 3 unnecessary ones and the Contact forms appeared.

    Thanks for your help!

    #70792

    Hi!

    Glad that you found the solution :)

    Best regards,

    Peter

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Contact form not loading; displaying Portfolio instead’ is closed to new replies.