Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #6607

    I cant seem to get my contact form to send an e-mail to myself.

    Can you think why it might not work?


    I’ve got the same problem as @TimTechLtd. http://www.woodmotorhomes.co.uk



    you should check your host if they’ve enabled the mail() function, this is often the cause of mails not sending.


    I’ve Checked with the host and it is enabled. What else is there to troubleshoot?


    My apologies It’s started working now. Not too sure why that is, but I’m not going argue with it.

    Thanks for your time, excellent theme by the way!


    Good to see it works now :)


    It happens the same to me.

    It does not send the email either shows the “congratulations your message sended”.

    Any idea?




    .. have you contacted your host as suggested?




    Alternatively you can use plugins like Contact Form 7.


    Couldn’t get the mail form to work. Tried Contact Form 7 but the design from Coalition does not get shown on the form.



    add following code to css/custom.css – this will style the Contact Form 7 fields:

    /*input fields*/

    .wpcf7-form textarea{
    font-family: Arial, Helevtica, Verdana, san-serif;

    .wpcf7-text, .wpcf7-submit, .text_area{
    font-family: Arial, Helevtica, Verdana, san-serif;

    padding:7px 12px 6px 12px;
    border-style: solid;
    border-width: 1px;

    .wpcf7-text, textarea, select {
    background: none repeat scroll 0 0 #F8F8F8;
    border: 1px solid #EEEEEE;

    .wpcf7-submit {
    background-image: url("../images/skin-minimal/arrow-right-white.png");
    background-position: right center;
    background-repeat: no-repeat;


    Ahhh, thanks Dude. I was having a look myself and I like the effect of the Coalition form.

    But there is a weird problem – not even the Contact form 7 works. Now the thing is this WP MU install is on a different directory on the same server as my personal blog, where I have the single website WP and the Contact form 7 plugin has worked fine.

    Any ideas?


    I think this is a hoster problem then because Contact Form 7 works even with “troublemakers” (i.e. Hostgator) which breaks our contact form or other plugins like Formidable. It seems like the wp_mail: http://codex.wordpress.org/Function_Reference/wp_mail or the php mail: php.net/manual/en/function.mail.php function doesn’t work properly on your server (maybe the hoster blocks something, etc.)


    Hi Dude

    I think you might be on to something re posssible blocking. I have posted the problem on the WP contact 7 forum here


    I am now working with the hosting provider as I found out that if I set certain e-mail addresses t works and if certain others it doesn’t. Spam filters and Akismet are not an issue, the latter is turned of anyway. All the e-mails I used otherwise work fine for sending and receiving mails.

    Will keep you updated…


Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Contact form not sending e-mail’ is closed to new replies.