Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #17261

    Hello, first of all I’d like to say how great this theme is! I have a few questions though:

    1) I don’t receive any emails after submitting the Contact form. I’ve had problems with Contact forms before, so installed the WP-Mail-SMTP plugin to specify that email is sent via my own SMTP server, and this has worked fine with other Contact forms. However this doesn’t appear to have any effect on the Contact form installed with this theme. Can you recommend how to get this working?

    2) Is there a way of removing the title from the top of the page within portfolio items? E.g. Take a look at this portfolio item: http://www.danielgallo.co.uk/post/using-controllers-in-a-sencha-touch-project – the title is already given further down the page, below the image, so I was hoping to remove the other title from above the image. Is this possible, just for Portfolio items?

    Many thanks.

    #94756

    Hey danieljgallo,

    The contact form uses wordpress’s own wp_mail function so if other contact forms worked it shouldn’t have any issues either. Double check that the receiving mailbox isn’t blocking the messages in some way and perhaps try some other addresses to be sure.

    If all else fails you can replace the built in form with a plugin that suits your needs as it doesn’t really have anything too special that a plugin couldn’t replace or even do better.

    #2 – Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #top.single-portfolio .title_container .main-title {
    display: none;
    }
    #top.single-portfolio .single-portfolio-entry .title_container .main-title {
    display: inline;
    }
    #top.single-portfolio .title_container .container {
    padding-bottom: 0px;
    }

    This hides the title’s then re-shows the one further down the page and then removes the padding from the top of the page where the old title no longer shows so its not such a huge blank space.

    Regards,

    Devin

    #94757

    Thanks for the CSS – that works a treat.

    I found the problem with the comments not sending – looks like it’s a bug in one of your theme files. After a bit of digging, I found that the “class-form-generator.php” file had the “return wp_mail(…)” function call commented out, and instead just has “return true” included (on line 426). After un-commenting this line, the emails now send fine. I assume this was an oversight when releasing this particular version/theme?

    Thanks again.

    #94758

    Hi!

    I tagged this thread for Kriesi.

    Best regards,

    Peter

    #94759

    Hi!

    hm, actually uncommenting the line should not be necessary, the mail gets sent by the function a few lines above. But thanks for the notice, will have a look at it ;)

    Best regards,

    Kriesi

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Contact form problems, plus formatting question’ is closed to new replies.