Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #208436

    When I receive an email via our contact form, I’d like to be able to click ‘reply’ and have the user’s email (being collected in the contact form) automatically populated into the recipient field. I’ve done this before when building basic forms, but am not sure how to set this up within Enfold. Can you please help me?

    Thank you.

    #208458

    Hey Alexa!

    The contact form will use the email address the user entered into the “E-Mail” field of the contact form. If your mail client supports the “Reply” feature it should automatically send the email back to the user email address and you don’t need to modify the theme code.

    Best regards,
    Peter

    #208462
    This reply has been marked as private.
    #208621

    Hi!

    No, please create me an admin account and post the login credentials as private reply. I just tested it with a form on my test server and the recipient field worked with my gmail and ymail account. You must make sure that the email address of the administrator (“Enter the Email address where mails should be delivered to.” option field on the “Edit” page) and the email address you use to test the form are different – otherwise you’ll send an email from your account to your account and then the recipient field won’t work (or actually it doesn’t make sense).

    Best regards,
    Peter

    #208707
    This reply has been marked as private.
    #208881

    Hi!

    I can’t modify the theme files and debug the issue (because I don’t have admin rights) but you can try to use this code to use the email field address as mail sender.

    
    add_filter('avf_form_from', 'avia_change_from', 10, 3);
    function avia_change_from($from,$new_post,$params){
    $from = $new_post['e-mail_1'];
    return $from;
    }
    

    - insert the code at the very bottom of functions.php. If it doesn’t work please give me admin rights – otherwise I can’t debug the code.

    Best regards,
    Peter

    #218432
    This reply has been marked as private.
    #218672

    Hey!

    Ah ok. This limitation explains everything because it forces you that the “sender” address is (Email address hidden if logged out) and the contact form can’t use a different email address for the sender. You may try to use smtp: http://wordpress.org/plugins/easy-wp-smtp/ – maybe it allows you to bypass this restriction. If not I recommend to switch to another host or to live with the restriction.

    Regards,
    Peter

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.