Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #8766

    Hi,

    I try to use Contact forms but don´t shows special characters, for example áéíóú, i see it:

    Content-type: text/html; charset=utf-8

    From: info@xxxx

    X-Brightmail-Tracker: AAAAAA==

    X-Brightmail-Tracker: AAAAAA==

    ¡Gracias por tu mensaje!

    Esta es una respuesta automática, en breve contactaremos contigo.

    Your Message:

    Nombre: prueba 4
    e-mail: xxxxxx
    Asunto: prueba 4
    Presupuesto: 500 € – 1.000 €

    Mensaje: áéíóú

    i check in my sql and it select collate utf8_spanish_ci

    How can solve this?

    Thanks!!!

    #62296

    I forgot a detail, I receive mails in plain text but my client outlook it´s select to view in html.

    #62297

    Hey,

    You can try to replace following line in abundanceframeworkphpclass-form-generator.php:

    mail($to, $subject, $message, $header);

    with:

    $subject = utf8_decode($subject);
    $message = utf8_decode($message);
    mail($to, $subject, $message, $header);

    #62298

    Hi,

    I try you solution and don´t work i have the same issue:

    Content-type: text/html; charset=utf8

    From: xxxx

    X-Brightmail-Tracker: AAAAAA==

    X-Brightmail-Tracker: AAAAAA==

    ¡Gracias por tu mensaje!

    Esta es una respuesta automática, en breve contactaremos contigo.

    Your Message:

    Nombre: prueba 6
    e-mail: xxxx
    Asunto: prueba 6
    Presupuesto: 500 € – 1.000 €

    Mensaje: áéíóú

    Also i reset all my vps server

    #62299

    I changed the code above a bit. Please try it again. Make also sure that it’s not a client side problem (send it to sever email adresses, view it with several webmail clients/email clients, etc.). You can also try to use plugins like: http://wordpress.org/extend/plugins/contact-form-7/ or Formidable.

    #62300

    I try the two options and don´t work and also check clients mails and have the same error don´t work.

    i see this info but i´m not sure this true,

    utf8_decode change character to ISO-8859-1 but euro symbol was introduce in ISO-8859-15

    Budget dropdown: 500 € – 1.000 €,

    have you any ideas? i´m also check config in server again.

    #62301

    Have you tried http://wordpress.org/extend/plugins/contact-form-7/ or Formidable ? If those plugins show the same error it has something to do with the database or php configuration.

    #62302

    I try contac from 7 and work fine:

    De: Jorge <xxxx>

    Asunto: prueba nuevo 2º áñéíóú

    Cuerpo del Mensaje:

    prueba nuevo 2º áñéíóú

    Este email se ha enviado vía formulario de contacto desde xxxx

    but I would like to use your contact form I think its appearance, use and performance is much better!

    ¿its possible solve this bug?

    #62303

    Sorry i forget a question:

    in http://www.kriesi.at/contact you use the same system? If yes, what do you think if i try send to you a menssaje to view if work fine with accents.

    #62305

    I try your server and i have the same bug, don´t shows special characters, for example áéíóú:

    Content-type: text/html; charset=utf-8

    From: altas@

    Message-Id: <20120202184731.516A51F246EB@dd5110.kasserver.com>

    Date: Thu, 2 Feb 2012 19:47:31 +0100 (CET)

    X-Brightmail-Tracker: AAAAAA==

    X-Brightmail-Tracker: AAAAAA==

    Thanks for your message! This is an autoresponder, set in the propulsion backend ;)

    Your Message:

    Name: prueba
    E-Mail: altas@
    Subject: Prueba áéíóóññ
    Priority: Low

    Message: Prueba áéíóóññ

    I have read the general terms and conditions and I agree!:

    Content-type: text/html; charset=utf-8

    From: altas@

    Message-Id: <20120202184730.E984E1F246E (Email address hidden if logged out) >

    Date: Thu, 2 Feb 2012 19:47:30 +0100 (CET)

    X-Brightmail-Tracker: AAAAAA==

    X-Brightmail-Tracker: AAAAAA==

    Name: prueba
    E-Mail: altas@
    Subject: Prueba áéíóóññ
    Priority: Low

    Message: Prueba áéíóóññ

    I have read the general terms and conditions and I agree!: true

    I think you have a bad sentence in your code … and when send messaje to server don´t use utf8 or html, sorry i don´t know the answer.

    #62306

    To be honest I think it’s probably a mail client problem because it works with ymail, my web mail account, etc. – however I’ll report it to Kriesi…

    #62307

    OK, I hope your answer.

    #62308

    I’ve asked to my vps server provider about this question and answer me this:

    “when converted to utf-8 check the mime encoding try to imitate some that converts thunderbird mail.”

    I hope this helps

    #62309

    Hi,

    have you any news, about this bug?

    Thanks!

    #62310

    Hey Antrax!

    Unfortunately I wasnt able to find the cause for the error. We will probably need to wait if other users got similar problems so we can do an educated guess on why this happens. In the meantime I am afraid you will need to use a 3rd party plugin if you want to circumvent the error.

    Once I have found a solution for the problem I will update the theme accordingly.

    Best regards

    Kriesi

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Contact forms don´t shows special characters’ is closed to new replies.