Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21844

    Hi,

    I have tried to figure out, why in the file framework –> php –> class-framework-widgets.php

    around line 854 the combo widget does not show the “comments” tab

    function widget($args, $instance)

    {

    // prints the widget

    extract($args, EXTR_SKIP);

    $posts = empty($instance) ? 4 : $instance;

    echo $before_widget;

    echo "<div class='tabcontainer tab_initial_open tab_initial_open__1'>";

    echo '<div class="tab first_tab widget_tab_popular"><span>'.__('Popular', 'avia_framework').'</span></div>';

    echo "<div class='tab_content'>";

    avia_get_post_list('cat=&orderby=comment_count&posts_per_page='.$posts);

    echo "</div>";

    echo '<div class="tab widget_tab_comments"><span>'.__('Comments', 'avia_framework').'</span></div>';

    echo "<div class='tab_content'>";

    avia_get_comment_list( array('number' => $posts, 'status' => 'approve', 'order' => 'DESC') );

    echo "</div>";

    echo '<div class="tab last_tab widget_tab_categories"><span>'.__('Categories', 'avia_framework').'</span></div>';

    echo "<div class='tab_content'>";

    wp_list_categories('sort_column=name&optioncount=0&hierarchical=0&show_count=1&title_li=');

    echo "</div>";

    echo "</div>";

    echo $after_widget;

    }

    What is wrong with this code?

    Thanks.

    #113303

    [EDIT]

    I have tried to replace in this part the line starting with “avia_get_comment”…

    echo '<div class="tab widget_tab_comments"><span>'.__('Comments', 'avia_framework').'</span></div>';

    echo "<div class='tab_content'>";

    avia_get_comment_list( array('number' => $posts, 'status' => 'approve', 'order' => 'DESC') );

    echo "</div>";

    with the line of the “tag” tab, which is working well, just to isolate the error:

    echo '<div class="tab widget_tab_comments"><span>'.__('Comments', 'avia_framework').'</span></div>';

    echo "<div class='tab_content'>";

    wp_tag_cloud('smallest=12&largest=12&unit=px');

    echo "</div>";

    and it still shows no “Comments” tab. I don’t know PHP, I solve a lot with try&error, but it seems, that something in the first line is wrong:

    echo '<div class="tab widget_tab_comments"><span>'.__('Comments', 'avia_framework').'</span></div>';

    #113304

    Kriesi just hided the content with css – you can use:

    #top .sidebar .widget_tab_comments, #top #footer .widget_tab_comments {
    display: block;
    }

    to display it. You maybe need to adjust the padding of the tabs with:

    .js_active .widget .tab {
    padding: 3px 8px 5px;
    }

    #113305

    Thanks a lot, works fine now!

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘CORONA's combo widget doesn't show latest comments’ is closed to new replies.