Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #19998

    Hi,

    I just added one contact form (Formidable Pro) and the CSS is all messed up if I add it inside one short-code column [one_half first]: http://d.pr/i/7R5D/1YB2uRAr

    However, at the bottom of this very page, and outside any columns, I just added the exact same form and it is showing perfectly: http://d.pr/i/Ex7Q/3soAq9AQ

    What can I do to have the CSS inside the short-code columns not so restrictive and more flexible to let me use the other CSS?

    The website URL is: http://d.pr/DBqz/4qtakBIg

    Many thanks

    #105918

    Hi,

    If you have access to the css styling of the Formidable Pro forms. Copy all of it then place it on custom.css. It will override the theme default styling.

    Regards,

    Ismael

    #105919

    Hi Ismael,

    It didn’t work.

    The “columns” shortcode CSS is still messing it up.

    I installed a 3rd party “column shortcode” plugin and the forms worked fine however, they are not responsive which kills the idea of keeping that plugin.

    How can I easily override the column shortcode CSS?

    Many thanks

    #105920

    Hi,

    Are you really attached to that formidable pro? Have your tried Contact Form 7?

    Thanks,

    Nicik

    #105921

    Hi Nick,

    Contact Form 7 is not good enough for my needs I’m afraid.
    Formidable is my first option – works better for my needs, but Gravity Forms might be my second alternative.

    I found similar problems in a Google search and this seems to be the most accurate related to mine: http://d.pr/piOg/4pHdSl2P
    However, the fix didn’t work: http://d.pr/5jPP/3tzylPe7 – the [raw] [/raw] around the form shortcode doesn’t work.

    Appreciate if anyone knows how to “prevent shortcodes from getting double filtered” which seems to be the cause of the problem.

    Many thanks.

    #105922

    Formidable support is pointing this issue to the theme support: http://d.pr/FhmV/3ugUK7oK

    Any help please?

    #105923

    Hey! Seems the wordpress autop function and the contact form do not play well together. its not really a css issue but a lot of unnecessary br tags are created.

    The easiest way to fix this is by adding this to your custom.css file:


    .flex_column .frm_form_fields br{display:none;}

    #105924

    The fix worked perfectly.

    Thank you Kriesy :)

    #105925

    Hi!

    Great glad we could help ;)

    Best regards,

    Kriesi

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘CSS column short-code messing up contact forms’ is closed to new replies.