Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2609

    Hello Kriesi!

    Hello everyone!

    Could you please let me know if anyone tried to create Cufon fonts for Japanese or Chinese?

    I tried to create a CufonFont.font.js as explained at http://www.kriesi.at/support/topic/cufon#post-83 and http://cufon.shoqolate.com/generate/ but it seems like the font is too large, so it gets rejected by http://cufon.shoqolate.com/generate/.

    So i tried to install everything on my Linux server and make one myself – as explained here https://github.com/sorccu/cufon/wiki/FAQ#faq-6

    I succeded to create a CufonFont.font.js and uploaded it to Fonts folder of the Avisio theme. The result is that japanese characters are now displayed, BUT the font is completely different from what i inteded. No matter what font I use to generate Cufon, the result is still the same ugly font.

    QUESTIONS:

    1. Is it even possible to create a Japanese (日本語) or Chinese Cufon font? if so – how?

    2. If not – Can i disable Cufon in Avisio?

    3. Can I change default font family for areas other than Cufon?

    4. As soon as I installed Avisio – the font in the menu bar (Home, About, Contact) was quite different from what it looks like at the demo page. How can I fix that?

    Thank you

    #38664

    1) It should work because cufon works with cyrillic letters too. But I can’t promise it.

    2)You can disable cufon by deleting following code in kclass_advanced_css_style.php located under framework/classes

    if(empty($font)) return;
    $this->scripts .= "<script type='text/javascript' src='".get_bloginfo('template_url')."/framework/fonts/cufon.js'></script>n";
    $this->scripts .= "<script type='text/javascript' src='".get_bloginfo('template_url')."/framework/fonts/$font.font.js'></script>n";
    $this->scripts .="
    <script type='text/javascript'>n
    Cufon.replace('".$elements."',{

    fontFamily: 'cufon',
    hover:'true'

    });
    n
    </script>
    n
    ";

    3) Yes – open up style.css and search for following code:

    body{
    font-size:13px;
    font-family: Arial, Helevtica, Verdana, san-serif;
    line-height:23px;
    position:relative;
    }

    Change the “font family” attribute to your needs.

    4) Try to create your own menu under Appearance > Menu

    #38665

    Thanks a lot. This solves most my problems. I am still trying to create a Japanese Cufon.font.js but if I fail – will just disable it.

    I also think I have found a problem. When I change my font in Avisio Options to japanese/chinese font I created myself, the text becomes selectable. This means it is not Cufon – am I right? How can it be that the text is displayed with regular font instead of Cufon font?

    - If i gve you a font that supports Japanese – would you be so kind as to try to convert it for me?

    - Also, how big is font.js file usually if you include all the characters including cyrillic?

    as for Question 4) I have tried to create a menu from Apearence > Menu, but the font is still the same. Can I change the menu font anywhere?

    Thank you and Merry Christmas!!!

    #38666

    Hey,

    I don’t know why Cufon doesn’t work with japanese/chinese fonts. You can send me your font file and I can try to generate a cufon font file but I’ve the same resources as you have. So if it doesn’t work for you it won’t work for me either.

    Font files are usually very big because of the complex symbols.

    Do you have a link for me. The menu (normally) doesn’t have use a “special” font.

    #38667

    OK so the output. Cufon.font.js file should be large, right? Mine comes out at 80kb or less. I think this is the problem. Maybe Cufon does not covert those japanese/chinese symbols and disables itslef

    here is the Link http://www.ai-web-hosting.info/ As you can see – the font in the menu is different from what is displayed on your demo-page.

    Thank you

    #38669

    Hey,

    you changed the font family – so the menu fonts changed too.

    You can try to add following to style.css:

    #head{
    font-family:Arial,Helevtica,Verdana,san-serif;
    }

    this should fix your problem.

    #38670

    Hello dear Kriesi.

    Could you please also let me know how to disable Cufon (or possibly change fonts) in CleanCut theme?

    Thank you

    #38671

    Hey,

    in header.php delete following code:

    $k_option['custom']['styling']->set_cufon_font($applyCustomFontTo, $k_option['general']['font_heading']);

    That’s it :)

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Cufon and Asian (Chinese, Japanese)’ is closed to new replies.