Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #26968

    I’ve been trying to get the cufon Cantarell to be part of the body text. But it doesn’t see to work. I replaced Century Gothic with ‘Cantarell’ then added the rest of the font types. The changes just reverted back to what looked like times new roman. I then just had the cufon by itself and that didn’t work either. I’m sure I’m doing something wrong, I just don’t know what it is. Here is the site http://maxxmount.com/our-solution

    I’m using the following code:

    font-family: Century Gothic, Verdana, Arial, Helvetica

    }

    Thanks in advanced.

    Carla

    #132283

    Hi!

    Open up wp-contentthemesflashlightincludesadminregister-styles.php and replace

    'elements'	=> '.cufon_headings',

    with

    'elements'	=> '.cufon_headings,.entry-content',

    Best regards,

    Peter

    #132284

    Peter,

    Thanks. I was able to change the font type but then it changed all my line spacing to double. I also can’t bold either. I added bold to a heading in one of my pages and it does nothing. The code is there but it doesn’t show up. One more thing, on the single product page. How to I get rid of “Product Description” title.

    Thanks

    Carla

    #132285

    I figured out how to get rid of the “product description” title and single line spacing but there is much space between the paragraphs. It’s double and I just need single. Bold issue still not resolved yet either. Thanks

    #132286

    I found a code that worked. Just in case someone else uses cufon for body text use this code to get rid of the double spacing issue.

    cufon[alt=""], cufon[alt=" "] { display: none !important; }. Now just to find a solution for getting the font to bold. I’m assuming that it’s also a cufon issue. Any ideas would be helpful as well.

    #132287

    Hi Carla,

    Each cufon font has to have bold added into that font file or the font file created with bold in it. I don’t think any of the pre-generated fonts that come with the theme have bold with them so you would need to re-generate the font files with this tool including bold http://cufon.shoqolate.com/generate/

    Regards,

    Devin

    #132288

    Devin,

    LOL. I was hoping for a simpler answer. Ok. I’ve never done this before. I’m sure I will have questions once I generate the file. I’m assuming I will have to upload via FTP but not sure where to put it. Stay tuned….

    Carla

    #132289

    Devin,

    I tried to change the file but it did not work. I’m not sure if I’m doing it right. I chose the cantarell.font.js. file to change the code for bolding but it said I didn’t have permission from the author to change it. Any ideas? thanks

    #132290

    Hi,

    Go here, and get the base font (‘download ttf’ button). http://www.fontsquirrel.com/fonts/Cantarell . You should download a zip inside of which are 4 ttf files , for bold, regular, oblique, bold oblique. Unzip them somewhere on your desktop.

    Now go to URL that Devin provided.

    Here is how I filled out that form. http://i.imgur.com/yU2G57h.png Use that as a template. Add the files you get from the zip from fontsquirrel. You may want to click the All checkbox, which i didn’t do in image.

    At the end it spit out a .js file which is what is needed. I would start with Bold alone, if that’s what you need. Rename the js file to the name of original you are using.

    Thanks,

    Nick

    #132291

    Nick,

    Ok, I did the changes but it doesn’t seem to have worked. I the file I replaced was located in flashlight/framework/js/fonts. I’m assuming that is where the new file should go since I couldn’t find that particular file anywhere else. I renamed the new file the same as the old one (cantarell.font.js). I replaced it and then went the page I needed some words bolded. It still looks the same. On this page, http://maxxmount.com/our-solution, the heading called “The Predicament” should have changed to bold.

    I’m I missing something? Do I need to have any custom css or change something in the register-styles.php file?

    Thanks again for all the help.

    Carla

    #132292

    Hi,

    Lets try it this way.

    I pasted what should go inside the cantarell js font file right here http://pastebin.com/UrqqyEfT

    Try it that way

    —-First try the above alone. Below I incuded some js specific to the above

    This goes inline in header.php before the </head> tag

    <script src="http://cufon.shoqolate.com/js/cufon-yui.js" type="text/javascript"></script>
    <script src="cantarell.cufonfonts.js" type="text/javascript"></script>
    <script type="text/javascript">
    Cufon.replace('.cantarell_bold', { fontFamily: 'Cantarell Bold', hover: true });
    </script>

    If doesnt work, please show url to some page in your site which tries to implement this font.*Make sure to change he url and name of file of the cantarell.cufonfonts.js in the block above to match location/name of your file.

    Thanks,

    Nick

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Cufon font in body’ is closed to new replies.