Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #22292

    I dropped the $15 to buy Revolution Silder but it doesn’t work with Propulsion. It may be a Jquery conflict with the existing slider built-into Propulsion.

    How do I disable the slider altogether so I can test this? I’ve disabled all plugins: no dice. I can get RS to work in the admin interface, so I know it works. But on the site itself it doesn’t — just gives me a grey box where the content is supposed to be.

    Thanks!

    #115282

    Can you post a link to your website please (to the page where you try to use the slider) – maybe the console gives us some hints why the slider doesn’t work (js errors, etc.).

    #115283

    Here’s a test page that shows the problem:

    http://www.hainsworth.com/revolution-slider-test/

    thanks in advance,

    Michael

    #115284

    I think the problenm is that wordpress adds paragraph tags to your code:

    <p>			<script type="text/javascript"></p>
    Uncaught SyntaxError: Unexpected token <
    <p> var tpj=jQuery;</p>
    <p> tpj.noConflict();</p>
    <p> var revapi2;</p>
    <p> tpj(document).ready(function() {</p>
    <p> if (tpj.fn.cssOriginal != undefined)
    tpj.fn.css = tpj.fn.cssOriginal;</p>
    <p> if(tpj('#rev_slider_2_1').revolution == undefined)
    revslider_showDoubleJqueryError('#rev_slider_2_1');
    else
    revapi2 = tpj('#rev_slider_2_1').show().revolution(
    {
    delay:9000,
    startwidth:960,
    startheight:350,
    hideThumbs:200,</p>
    <p> thumbWidth:100,
    thumbHeight:50,
    thumbAmount:1,</p>
    <p> navigationType:"bullet",
    navigationArrows:"solo",
    navigationStyle:"round",</p>
    <p> touchenabled:"on",
    onHoverStop:"on",</p>
    <p> navigationHAlign:"center",
    navigationVAlign:"bottom",
    navigationHOffset:0,
    navigationVOffset:20,</p>
    <p> soloArrowLeftHalign:"left",
    soloArrowLeftValign:"center",
    soloArrowLeftHOffset:20,
    soloArrowLeftVOffset:0,</p>
    <p> soloArrowRightHalign:"right",
    soloArrowRightValign:"center",
    soloArrowRightHOffset:20,
    soloArrowRightVOffset:0,</p>
    <p> shadow:2,
    fullWidth:"off",</p>
    <p> stopLoop:"off",
    stopAfterLoops:-1,
    stopAtSlide:-1,</p>
    <p> shuffle:"off",</p>
    <p> hideSliderAtLimit:0,
    hideCaptionAtLimit:0,
    hideAllCaptionAtLilmit:0,
    startWithSlide:0
    });</p>
    <p> }); //ready</p>
    <p> </script></p>
    <p> <!-- END REVOLUTION SLIDER --></p>

    Try to use a shortcode for the slider instead or use a “raw code” plugin to embed the js code.

    #115285

    I did use the shortcode, actually. I’ve never seen WP add paragraph tags before. And it doesn’t affect other themes, just Propulsion.

    #115286

    Hi Michael,

    I don’t know of anything within the theme that would add them in but I’ve tagged Kriesi on the topic as he would know for sure one way or another.

    Regards,

    Devin

    #115287

    Thank you. If there’s a way to rip-out the existing slider, that’d be great. I think we’re seeing a Jquery conflict since the Revolution Slider looks fine in preview in the back-end admin interface, just not live.

    #115288

    Update: it appears Revolution Slider uses a newer JQuery than Propulsion. When I removed the file “propulsion/js/jquery.js” it appears the Revolution Slider’s version of JQuery takes over — and existing JQuery based calls by Propulsion continue to work (the content slider, specifically).

    So the issue is a conflict in versions. Propulsion uses 1.8.3 and Revslider uses 3.5.1.

    RESOLVED.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Disable built-in slider so Revolution Slider works?’ is closed to new replies.