Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #14450

    On my portfolio item pages, I do not want the image to be clickable or to open up in a lightbox.

    I commented out this code

    wp_enqueue_script( 'avia-prettyPhoto' );

    I also selected None for the image url when I uploaded the images.

    But when I mouse over the image I still see a magnify glass and the image opens in a blank window when i click it.

    Any tips on how to disable this completely?

    #83505

    Any help on this?

    #83506

    /////////EDIT to my Question

    The code below seems to work, BUT it also disables all my thumbnail images. How do I disable the of a larger image on my single portfolio items, but keep the ability to click the smaller images/thumbnails?

    jQuery(document).ready(function(){

    jQuery('.content .featured').find('img').unwrap();

    #83507

    Can somebody please help on this? Thank you

    #83508

    Hello,

    To disable lightbox. Open up js > avia.js and find this code

    //activates the prettyphoto lightbox
    if(jQuery.fn.avia_activate_lightbox)
    jQuery('body').avia_activate_lightbox();

    Replace it with this.

    //activates the prettyphoto lightbox
    //if(jQuery.fn.avia_activate_lightbox)
    //jQuery('body').avia_activate_lightbox();

    To disable the link on your portfolio image, on your “Add featured media” metabox, look for “Apply link to the image?” and select “No link”.

    Regards,

    Ismael

    #83509

    That doesn’t work. Once I select “no link” my thumbnail images no longer open my portfolio entries.

    #83510

    Hi lindsayclineco,

    You can set it to “Link to this Post”, so the portfolio entry will show up if the image is clicked. :)

    Regards,

    Ismael

    #83511

    Right. When I do that, my main portfolio image then opens to a new window. I don’t want that to happen.

    All I want to do is keep the thumbnails clickable in the portfolio and not have the featured image open to a new window or lightbox when it’s clicked on a portfolio item page.

    #83512

    Hello,

    To be more specific are you talking about the Featured Image on portfolio overview or the single portfolio view?

    Regards,

    Ismael

    #83513

    I’m trying to disable the ability to click the featured image on the single portfolio view. But I do not want to disable the featured image on the overview (thumbnails).

    #83514

    Hi!

    Try following code – it will affect the single portfolio pages only:

    jQuery(document).ready(function(){
    jQuery('.single-portfolio .content .featured').find('img').unwrap();

    Best regards,

    Peter

    #83515

    That works like a charm.

    Thank very much!

    #83516

    Glad that worked for you :)

    Regards,

    Devin

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Disable Lightbox and Clickable Portfolio Image?’ is closed to new replies.