Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7084

    Is there any way to disable the lightbox function on the sidebar or for specific links?

    I installed a social media widget with links to both my Vimeo and YouTube accounts, but the links are automatically interpreted as video links (lightbox feature), which doesn’t work.

    http://www.yellowbatmedia.com

    Thanks!

    #56538

    Hey,

    you can add the “noLightbox” class to your video links – the code looks like:

    <a class="noLightbox" href="http://www.youtube.com/">Youtube</a>

    #56539

    Hey guys!

    I’m having the same problem. However, my vimeo link is part of a menu. Therefore the only place I type in the url for the link is the “URL” section for this particular menu option. I have no way of going into “source” mode or HTML coding to put in your above code. I also do not want to disable the entire lightbox feature for my site, as I like having it for certain things…any ideas on how to isolate this problem?

    Thanks so much in advanced!

    -Brent

    #56540

    Hey,

    Go to the menu manager page (Appearance > Menus) and search for the “Screen Options” tab at the right top corner. Click on it and a dropdown will open. Select/chech the box nect to “Link Relationship (XFN)”. A new input field will be displayed for each menu item with the headline “Link Relationship (XFN)”. In this input field insert “noLightbox” without “”.

    #56541

    Hey. Thanks for the quick reply! I did everything exactly as you said and it still isn’t working. I still get the lightbox turning wheel that doesn’t go away. Just to be clear this is all I put in the Link Relationship field:

    noLightbox

    I tried different variations of it for kicks and still nothing. Any other thoughts?

    -Brent

    #56542

    Ok, just in case anyone reads this. I was able to figure it out. It is NOT in the Link Relationship field like mentioned above. In fact it is in the CSS Classes field. Makes sense. Thought I had tried that before but turns out when I toggled the open in new tab check off then on again, it worked!

    So again, correction. Not Link Relationship field. CSS Classes field.

    -BB

    #56543

    Glad that you found the solution. I totally missed that the rel attribute initialises the lightbox only.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Disabling lightbox function for specific links’ is closed to new replies.