Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #14321

    How do you display the entire blog post instead of the title and a preview in the blog feed? My Reading Settings are already set to display the entire text, but for some reason the feed is still showing just a preview. Is there something within the theme that I have to change to make this work?

    Any help is appreciated.

    Edit: Also, is there a way to remove/change the lightning bolt icon between blog posts?

    Edit 2: Is there a way to have your Twitter and Facebook pages open in a separate page? I tried adding target=”_blank” to the links within the sidebar.php file but got an error message. Any ideas?

    #82918

    Hi,

    Just for clarification – Are you referring to your RSS feed or your actual blog page?

    To remove the lightning bolt icon add this to your custom.css or Quick CSS:

    .hr {
    background: none no-repeat scroll center center #eeeeee;
    }

    What that will do is remove the lightning bold image but keep the grey line.

    Now with the Facebook and Twitter links you have to be careful about the ” you use in “_blank” so you’ll want to type it like this:

    if($facebook = avia_get_option('facebook')) echo "<li class='facebook'><a target='_blank' href='".$facebook."'>Facebook</a></li>";
    if($twitter = avia_get_option('twitter')) echo "<li class='twitter'><a target='_blank' href='http://twitter.com/".$twitter."'>Twitter</a>

    Regards,

    Mya

    #82919

    Thank you for your help, Mya. I’m referring to the actual blog page, not the RSS feed.

    #82920

    I tried adding that code to my custom.css file and the lightning bolt icon disappeared but there it’s been replaced by a box that overlaps with post content. See what I mean here: http://pinebrand.com/blog/?page_id=201. Do you have any idea how to fix this? Thanks again for your help.

    #82921

    Hello,

    To remove the lightning hr just put this on your custom.css

    .hr {
    display: none;
    }

    Flashlight by default will show the whole blog posts unless you put <!– more –> on your post editor which will designate the above text as excerpt.

    Regards,

    Ismael

    #82922

    Thanks for the response Ishmael.

    I still can’t get embedded videos/images to show up in the blog feed without clicking through to the single post that they are embedded in. Feel free to look at my website to see what I’m referring to at http://pinebrand.com/blog/?page_id=201. The most recent post has a .png embedded in it but it does not show up on the feed until you click through to the individual post.

    Also, when I search my site’s URL in Google, the following comes up:

    ScreenShot2012-07-20at112747AM.png

    How can I remove this warning and replace it with text?

    Thanks again,

    Garrett

    #82923

    Hello,

    Please send your admin details on (Email address hidden if logged out) . Include this thread on your email to avoid being detected as spam.

    Regards,

    Ismael

    #82924

    You have an email.

    #82925

    Tagging this for Ismael so he’ll have a quick link.

    Regards,

    Mya

    #82926

    Same here, I don’t have the entire blog post on the Blog page (text + pictures)

    And also, I have set up a page as Home Page, which then shouldn’t show the blog posts, but it does. It displays the content of my page and the latest blog post, which I don’t want at all

    #82927

    Hello,

    @garrettdaniel: your site is fine now. :)

    Open up your loop-index.php, look for this code

    the_excerpt();

    Replace it with

    the_content();

    Regards,

    Ismael

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Display entire blog posts in feed’ is closed to new replies.