Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #14457

    How do you display the entire blog post instead of the title and a preview in the blog feed? My Reading Settings are already set to display the entire text, but for some reason the feed is still showing just a preview. Is there something within the theme that I have to change to make this work?

    Any help is appreciated.

    Edit: Also, is there a way to remove/change the lightning bolt icon between blog posts?

    Edit 2: Is there a way to have your Twitter and Facebook pages open in a separate page? I tried adding target=”_blank” to the links within the sidebar.php file but got an error message. Any ideas?

    #83543

    Hi garrettdanielson,

    To change the lightning bolt icon, you just need to change out the image for the skin you are using. So for the default minimal skin the file is in:

    flashlight/wp-content/themes/flashlight/images/skin-minimal/hr.png

    To display full blog posts on the Blog overview page you’ll need to open includes>loop-index.php and search for:

    if(is_search() || avia_is_overview())

    Replace that with:

    if(is_search())

    Save the file and that should then display the full post unless you have a <!–more–> tag breaking it up manually.

    For the Twitter and Facebook icons, you might have just not added it in the correct format. Try replacing the following in sidebar.php:

    if($facebook = avia_get_option('facebook')) echo "<li class='facebook'><a href='".$facebook."'>Facebook</a></li>";
    if($twitter = avia_get_option('twitter')) echo "<li class='twitter'><a href='http://twitter.com/".$twitter."'>Twitter</a></li>";

    with

    if($facebook = avia_get_option('facebook')) echo "<li class='facebook'><a href='".$facebook."' target='_blank'>Facebook</a></li>";
    if($twitter = avia_get_option('twitter')) echo "<li class='twitter'><a href='http://twitter.com/".$twitter."' target='_blank'>Twitter</a>

    Regards,

    Devin

    #83544

    Sorry for bumping an old thread, but didn’t want to start a new one.

    I’m trying to have the whole blog post show up in the main blog page. My entries are not long, but usually include links which people have to go to the post page to see, and the blog roll only shows the text of it.

    I tried adding this to my functions.php:

    Code:
    add_filter(‘excerpt_length’, ‘my_excerpt_length’);
    function my_excerpt_length($length) {
    return 20; }

    and I tried Devin’s solution of changing the if(is_search()… line and putting in “the_content();” in the if statement.

    I still can’t get the full posts to show up on the main blog page.

    The page is http://jaszekphoto.com

    Thanks.

    #83545

    Hey, nevermind. It started working after about 3 hours for some reason.

    #83546

    Hey jaszek,

    Sounds like you might have been viewing some local cache. Whenever you are making updates just be sure to refresh your browser 3-4 times to make sure it re-downloads all the files from the server and doesn’t pull old files from your local storage.

    Regards,

    Devin

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Display entire blog posts / Other Issues’ is closed to new replies.