Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #127

    I wish to use Display with Gravity Forms, no problem with that however the Gravity Forms people must use the (li) and (ul) tags for displaying the form fields because it puts the little orange bullet next to each one.

    I specifically want to turn off this bullet image somehow but don’t know where to start, in CSS I guess?

    But just to be extra difficult, I only want to turn off the bullet specifcally for the Gravity Forms, or just for the main content area and revert to a “standard” bullet.

    Hope this helps :)

    #29928

    allthough i am not 100% shure what you need you can usually set a different list style for such plugins since in almost all cases they wrap their output code into a html element with a unqiue class or id. so i would recommend to check the souce of the page that got the forms applied and then add a unique css rule for these list items. for example if they use a form with id Gravity Forms you could use

    #top #gravity .ul li{
    background: transparent none;
    list-style-type:none;
    list-style-image:none
    }
    
    #29929

    Hmm, need to learn more about this CSS stuff.

    #29930

    Ok so the code it uses to display the form is like this…

    <div class='gform_wrapper' id='gform_wrapper_1' style='display:none'><form method='post' enctype='multipart/form-data' id='gform_1' class='' action=''>

    <div class='gform_body'>

    <input type='hidden' class='gform_hidden' name='is_submit_1' value='1'/>

    <ul id='gform_fields_1' class='gform_fields top_label'><li id='field_1_2' class='gfield' ><label class='gfield_label' for='input_1_2'>Your Name<span class='gfield_required'>*</span></label>

    so the ID would be gform_wrapper_1 or gform_fields_1 ?

    #29931

    Just as a sidenote, to include full support for Gravity Forms as the contact option would be a killer addition I feel :)

    #29932

    #top .gform_wrapper .ul li{
    background: transparent none;
    list-style-type:none;
    list-style-image:none
    }

    Should do the trick then. :)

    Since this is a premium paid plugin there are not that many people using it, therefore I dont think that adding those options would be that wise. However I will of course re consider if the plugin gets more popular ;)

    #29933

    I would think that Gravity Forms is a very popular plugin, I have a developer license :)

    #29934

    Well, you are the first one how ever asked me a Gravity Forms related question ;D

    #29935

    I feel “unique” and “special” hehe :)

    #29936

    Hi, I’m here about 1 year after with the same problem. I tried to include every code on every style.css I found here in the forums, but still have this issue.

    Please, can someone help me to correct this? I’m about 2 days on that with no success… I’m not a great webmaster, really…

    Here is the problem, all the forms becomes in “list” mode, but it is not visible on a clean theme.

    http://www.pulsarstudio.com.br/fix

    The only way I found to fix that was removing by hand every tag containing the “.gform_wrapper ul li.gfield” style, but I’m not really sure about what I’m doing.

    Can someone help me plz?

    Thanks in advance.

    #29937

    Try following css code (add it to style.css):

    .gform_wrapper li {
    background: none transparent !important;
    border-bottom: none !important;
    }

    #29938

    Hey… thanks so much for the help!!!

    It’s almost perfect, but there’s still some lines… is there anything else that I can do?

    http://www.pulsarstudio.com.br/fix

    Here is a preview of this form without a theme:

    http://www.pulsarstudio.com.br/formpreview.html

    Thanks again!

    #29939

    Hi,

    below what you previously added add

    .gform_body ul{
    border:0;
    }

    This should do the trick :) Let us know if it works.

    #29940

    AMAZING!!!!

    Thaaaaaaaaaaankssss!!!!

    #29941

    Good to see it works :)

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Display & Gravity Forms’ is closed to new replies.