Tagged: ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #16201

    The black navigation navigation bar below blog articles (navigate to the previous or next article) uses the full page width in Chrome or Safari but not in Internet Explorer, Firefox or Opera ( screenshot: http://d.visisoft.de/XKXs ). This also happens on the live demo at kriesi.at, so it’s nothing I changed.

    How can I change it to the full page width in Internet Explorer, Firefox and Opera?

    Thanks for any hints,

    Markus

    #90569

    Hi Markus,

    It looks like everyone except Chrome has an issue with using display:table. The quickest way to fix it would be to make a new rule for Chrome and change the default for everything else.

    Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    .post_nav {
    display:block;
    }
    html.chrome .post_nav {
    display:inline-table;
    }

    Regards,

    Devin

    #90570

    Thanks Devin, but that didn’t work. The navigation bar does use the full page width in all browsers now, but the text position isn’t correct, except in Chrome ( screenshot: http://d.visisoft.de/7dlY ).

    Any more hints?

    Regards,

    Markus

    #90571

    In that case,

    Try:

    .post_nav {
    display: block;
    }
    .previous_post_link_align {
    display: block;
    float: left;
    }
    .next_post_link_align {
    display: block;
    float: right;
    }

    And we’ll get rid of the table formatting all together. When the theme responds to a different resolution size (mobile or tablet size etc) the links will no longer span the entire column anymore since they float inside the container, but they shouldn’t have any other major issues.

    I’ll send the bug over to Kriesi and see if we can get a fix in the next theme update.

    #90572

    Thank you Devin,

    it worked, the navigation bar is now displayed correctly in all tested browsers.

    Please let me use this opportunity to thank kriesi.at for creating this awesome looking theme and for your product support!

    #90573

    Glad we could help :)

    I’ll send the update and issue over to Kriesi so it can be included in the next update or a more specific fix can be created by the big guy himself.

    Regards,

    Devin

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Display issue with black navigation bar below blog articles’ is closed to new replies.