Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #3346

    I have blog posts under the slider in the Newscast theme. The first one is a one-column style, and then there are 8 that are in the two-column style underneath the first one.

    The first post is a sticky post, and I would like for the full text of that particular post to show on the home page (including images as well). Is this possible?

    Thank you.

    #41772

    Hey,

    download the modified index.php and place it in the main directory of Newscast: http://www.mediafire.com/?anzqk3db3v4ja7a

    #41773

    That didn’t change anything. Any other suggestions?

    Thanks!

    #41774

    Hey,

    sorry the code I posted before was intended for someone else. I updated it.

    #41775

    Sorry, still no changes.

    There is no <?php get_sidebar(); ?> though.

    It reads <?php

    get_sidebar();

    get_footer();

    ?>

    I tried to delete several different combinations of <?php

    get_sidebar();

    get_footer();

    ?>

    but saw no changes. Any other thoughts?

    #41776

    Hey,

    sorry – I adjusted the instructions once again. Now it should work.

    #41777

    Where are the changes? It looks like all of your instructions on this thread have been deleted.

    #41778

    Download the modified index.php and place it in the main directory of Newscast: http://www.mediafire.com/?anzqk3db3v4ja7a

    #41779

    1. Can the featured post on the Home page (center page, not in the right column) be modified to show the entire post?

    2. Is there a way to determine where the “read more” code is inserted in this post?

    The post is entitled Welcome to Integrative Medical Group of Irvine and is on this page: http://66.147.244.248/~integry3/

    #41780

    Hey,

    1) I’m not sure what the “featured post” is (slider posts?) but if it’s the first post or a sticky post it’s possible. Slider posts would require some coding.

    2) You can use the read more tag – in visual mode it’s a button (two pages divided by a line – shortcode is Alt + Shift + T) on the toolbar, in html view use:

    <!--more-->

    or the more button.

    You need to adjust index.php a bit – replace:

    <div class="entry-text">
    <?php
    if($small_prev) echo $small_prev;
    the_excerpt();
    ?>
    </div>

    <div class="entry-bottom">
    <a href="<?php echo get_permalink() ?>" class="more-link"><?php _e('Read more','newscast'); ?></a>
    </div>

    with:

    <div class="entry-text">
    <?php
    if($small_prev) echo $small_prev;
    the_content(__('Read more &raquo;','newscast')); ?>
    ?>
    </div>

    <div class="entry-bottom">
    </div>

    #41781

    Hey Dude. I downloaded the index.php file and placed it in the main directory of Newscast. Still, there are no changes to my first post on the home page. Any other suggestions? Thanks!

    #41782

    Yes, I’m talking about the main post on the home page. Again, it’s the one entitled Welcome to Integrative Medical Group of Irvine which you can see at this link http://66.147.244.248/~integry3/ .

    I implemented the changes to index.php in newscast directory and placed a Read More tag <!–more–>, as suggested. The tag was placed after a second paragraph but still only the first paragraph shows. Any ideas? Do you need access to Admin?

    #41783

    Hi Newscast theme guys. Here I’m updating the status of my last entry:

    Yes, I’m talking about the main post on the home page. Again, it’s the one entitled Welcome to Integrative Medical Group of Irvine which you can see at this link http://66.147.244.248/~integry3/ .

    I implemented the changes to index.php in newscast directory and placed a Read More tag <!–more–>, as suggested. The tag was placed after a second paragraph but still only the first paragraph shows. Any ideas? Do you need access to Admin?

    If you look at the home page link above, you’ll notice that there is only one post in the bottom center of the page (Welcome to Integrative Medical Group of Irvine). This is because I’ve created a category called homepage and purposely put just one post in it. I’ve also excluded all the other categories in the OptionTree settings (would be great to have an option to just include 1 cat instead of excluding all but 1).

    These are the display problems I see on the home page related to this:

    1. The MORE tag at end of second paragraph of post is being ignored, and instead only the first paragraph is showing. (earlier suggested fix had no effect)

    2. There’s a navigation block showing 3 pages of posts, when there is only the 1 post. Also clicking on a page displays Nothing Found

    3. A HOMEPAGE button appears even though the user is already on the home page. (this one’s not a show stopper, just a rough edge)

    BTW, this is a really fine theme and support is good so far.

    #41784

    Another update:

    Partial success: Using the Excerpt field in the post did what the <!–more–> tag did not. Item 1 above is resolved.

    Items 2 and 3 are still open.

    #41785

    Yet another update:

    Item #3 was resolved by commenting out line 137 of index.php in the /newscast/ directory.

    Re: Item #2 – How can I get rid of the post pagination numbers that appear?

    Want only the one post Welcome to Integrative Medical Group of Irvine to show and not the pagination numbers that appear below it.

    #41786

    Hey,

    in index.php delete following code:

    kriesi_pagination($additional_loop->max_num_pages);

    #41787

    Perfect. Thanks.

    #41788

    Glad that I could help you :)

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘Display the full text of the first post on the home page.’ is closed to new replies.