Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #7538

    Need help with 2 issues:

    1. The jquery drop-down items on my top menu display correctly – but disappear as soon as I move my cursor to make a selection – which means I can’t select them.

    2. Finally figured out how to add page specific submenus in the side bar using custom menu widgets (as I don’t want just a repeat of the top menu) BUT they don’t display the same “active” or “current” behaviours as the ‘Submenu’ items

    Look here to see the problem I’m having….

    I would greatly appreciate instructions on how to resolve these issues.



    did you solve the first issue? It seems to work fine for me. I don’t believe it’s currently possible to have the “current” behaviour for the custom menu widgets. The standard ones should work fine. Maybe I’m wrong, – have you checked if your plugins interfere with the menu at all?

    Let us know :)


    Hi Chris,

    Yes, I solved the first menu issue by changing the css values for the drop-down menus in order to move the closer to the top menu text items, and they work now.

    Are you sure there isn’t a way for me to add a “current” behaviour for the custom menu widgets. It’s not really good interaction design for them not to be highlighted in some way to give a visual indicator of where the user is within the menu tree…. Which plugins are you referring to? I haven’t added any to the basic Display theme.

    Any help you can give would be appreciated.




    try adding this to your style1.css

    #menu-ogmatic li.current-menu-ancestor > a {
    color: #FF0099;

    .current-menu-item {
    font-weight: bold;

    The first two lines are for the menu color of the parent, the other lines are to make the current page highlighted.


    Hi Chris,

    It worked! Thank you SO much.


    Glad that I could help :)

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Display Theme: drop down menus & sidebar menus not working properly’ is closed to new replies.