Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #5351

    Is there a way to control where the read more links on the Display Theme cut off the text? I am using the 3 column format and the text within each column displays a rean more link which is cool but it seems to display a ton of text in the first column before showing up vs the other two columns. I am pointing to three pages and there is a decent amount of text in each.

    #49808

    Hey,

    you can use the read more tag: http://codex.wordpress.org/Customizing_the_Read_More to create the excerpt.

    #49809

    Hi, I am basically looking to perform the same thing. My Display theme site actually inserts the entire post in the main page columns re: http://ucfretrolab.org .

    I read the article linked, but it is not clearly stated what file we access to edit the template tag.

    Here is the closest I found, “The parameters within the template tag the_content() are as follows:”

    What file is the template tag housed in?

    Also, just to be clear, in order to have the trimmed excerpts for the main page columns I must edit the template tag as well as use the no more quicktag per post.

    Thank you! So far I am really enjoying using this theme.

    #49810

    ^ I’ve got it figured out! Thanks tho, this forum is uber helpful!

    #49811

    Hey,

    I think the frontpage shows only a part of the post (it ends with ….to each stage of deployment.). The post itself contains list and additional text. Did you solve the problem? The more tag is used like:

    and I told him that he should get moving or I'd be
    on him like a limpet. He looked at me with shock on
    his face and said

    <!--more-->

    in html view or you can click on the more tag “button” which can be found in the toolbar (Visual or Html mode).

    some other text….

    #49812

    I did solve it-but thanks so much! How about another question?

    Is it possible to have the main page columns click an individual designated post vs. a category? For example, instead of having my latest ‘serious games’ category post revealed, can I enter a manual link to an exact post in a category to be displayed in the main page columns?

    Thanks-R.

    #49813

    Hey,

    open up displayframeworkclasseskclass_display_box.php and replace following code:

    echo '<a href="'.get_permalink().'" class="more-link">Read more</a>';

    with:

    if (get_post_meta($post->ID, 'url', true)){
    echo '<a href="'.get_post_meta($post->ID, 'url', true).'" class="more-link">Read more</a>';
    }else{
    echo '<a href="'.get_permalink().'" class="more-link">Read more</a>';
    }

    Afterwards you can set post meta fields in all your posts/pages which should appear in your mainpage columns (pages/posts you set in the admin panel: Display Options > Mainpage Options). Call the fields “url” and type in the websites’ adresses as values. This post will tell you more about custom fields: http://www.kriesi.at/archives/how-to-use-wordpress-custom-fields

    #49814

    Tried it and I got the following error:

    “Parse error: syntax error, unexpected ‘<’ in /home/gregpard/public_html/ucfretrolab.org/retrolab/wp-content/themes/display/framework/classes/kclass_display_box.php on line 140 “

    I then deleted the redundant <?php and still got an error return for line 145. But I didn’t copy and paste it, sorry.

    -R

    #49815

    I corrected the code – it should work now.

    #49816

    Great thank you. I went to your linked site for WordPress custom fields, but I can not locate the:

    “to access these fields just head over to the write post/page site down to the Advanced Options Tabs. There you will find the Custom Fields Tab which looks something like this”

    Can I request a screencap of where in the WordPress editor I will find the Advanced Options tab?

    Thanks once again, all of your advice has been fruitful.

    -R

    #49817

    It looks like:

    Maybe you need to activate the fields – by using the “screen options” tab on the right top corner in your wp admin panel. Click that tab and a panel with additional options will open. Check the checkbox in “Custom fields”.

    #49818

    Hi, does this change the “read more”links that appear for portfolio categories that are listed on the portfolio template? I tried this same thing and it doesn’t seem to affect it when i added the custom field ‘url’

    #49819

    I tried this:

    <a href="<?php echo get_post_meta($post_id, $url, $single); ?>" class="more-link">Read More</a>

    to no avail

    #49820

    oops i solved it. I just replaced this into the portfolio template

    <a href="<?php echo get_post_meta($post->ID, 'url', true); ?>
    " class="more-link">View More!</a>

    #49821

    Hi shawnra,

    Glad that you’ve fixed it. :)

    Cheers,

    Ismael

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Display Theme Read More Links’ is closed to new replies.