Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #14235

    Hello everyone,

    I have several entries with a featured image that is showing on the feed page before entering to the entry url and thats ok, however I don´t want that featured image to be shown inside the proper entry (no it shows at the top of the entry and then the content is displayed).

    How can I set the featured image to be shown at my entries feed page, but not inside of the entry?

    Thanks!

    Nicolas

    #82567

    Hi Nicolas,

    Sounds like you’ll need to add a display:none; to your CSS file. Add this to style1.css, style2.css or style3.css depending on which skin you’ve chosen in the theme options.

    body.single .entry-previewimage {
    display: none;
    }

    Regards,

    Mya

    #82568

    Mya,

    Thanks for your help! It worked ok in all the entries however It affeted my pages as well. Is there a way to make that code work just for entries? Thanks!

    Nicolas

    #82569

    Hi Nicolas,

    Try replacing body.single with body.single-post. If that doesn’t work then I’ll need to see a link to the website so I can compare the pages.

    Regards,

    Mya

    #82570

    Mya great! That´s just perfect.

    I have one last issue. My post featured images on the feed page is are linking to my posts, but my featured image on my pages are not liking to those pages. Any idea on what´s happening?

    I´m using Custom Post Types, so I have a page where I list hotels, and each listing has a featured image that doesn´t link to the hotel page as the title of the hotel is correctly doing.

    If you need me to make my site public that´s ok!

    Thanks again!

    #82571

    Hi,

    Sounds like the link tag isn’t being placed around the feature image on your pages. I would need to see an example though before I could be sure. How are you inserting the featured images on those pages?

    Regards,

    Mya

    #82572

    Hi again!

    My site is http://chacrasdecoria.travel. As you will see on the home page if you clic a post featured image, that image links to the post url. However if you go to the hotel list http://chacrasdecoria.travel/hoteles/ and clic the featured image of a random hotel, It doesn´t have any link.

    For the hotel pages, I´m selecting the featured image from the WYSIWYG editor (on the righ column of the worpdress platform)

    Thanks for your help!

    #82573

    Hi,

    As suspected there’s no A HREF tag around the thumbnail image to provide the link like on the other page. Did you try using the Post Thumbnail Options box?

    Regards,

    Mya

    #82574

    Mya,

    Not sure what you mean about Post Thumbnail Options box. The process I do is clic set featured image, then selet the file from my library, set the image to link to the post and the confirm.

    However It doesnt work….

    #82576

    Hi saynw,

    If the Hotels is a custom post type, you’ll need to add in another option to that post type so that you can assign a URL to your featured image.

    Regards,

    Devin

    #82577

    Does anyone know how to do this with shoutbox??

    #82578

    Hi ffn,

    To featured images to Shoutbox, you would use the “Add featured media” section at the bottom of the page.

    Regards,

    Mya

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Do not show featured image on post’ is closed to new replies.