Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #13791

    Hi
    I am using Abundance theme and Gravity Forms.

    The dropdown menus are way too long..

    According to Firefox Inspector the style sheet that control that is woocommerce-mod.css

    The only CSS that i think it is is here…

    </p><br />
    <p>/*dropdowns*/<br /><br />
    .avia_style_wrap {<br /><br />
    position: relative;<br /><br />
    display: inline-block;<br /><br />
    padding: 6px;<br /><br />
    background: transparent url(images/bg-style-wrap.png) repeat-x bottom center;<br /><br />
    -webkit-border-radius: 6px;<br /><br />
    -moz-border-radius: 6px;<br /><br />
    border-radius: 6px;<br /><br />
    }</p><br />
    <p>.avia_select_unify {<br /><br />
    color: #586970;<br /><br />
    display: inline-block;<br /><br />
    border: 1px solid #eee;<br /><br />
    -webkit-border-radius: 4px;<br /><br />
    -moz-border-radius: 4px;<br /><br />
    border-radius: 4px;<br /><br />
    z-index: 1;<br /><br />
    background: white url(images/select.png) no-repeat right center;<br /><br />
    cursor: pointer;<br /><br />
    position: relative;<br /><br />
    }</p><br />
    <p>#top .avia_select_unify select {<br /><br />
    height: 32px;<br /><br />
    padding: 7px;<br /><br />
    width: 198px;<br /><br />
    background: white;<br /><br />
    position: relative;<br /><br />
    z-index: 10;<br /><br />
    opacity: 0;<br /><br />
    cursor: pointer;<br /><br />
    float:none;<br /><br />
    margin:0;<br /><br />
    }</p><br />
    <p>#top .avia_select_unify #shipping_method{<br /><br />
    width:145px;<br /><br />
    }</p><br />
    <p>.avia_select_fake_val {<br /><br />
    font-size: 12px;<br /><br />
    left: 7px;<br /><br />
    line-height: 31px;<br /><br />
    overflow: hidden;<br /><br />
    position: absolute;<br /><br />
    top: 1px;<br /><br />
    width: 200px;<br /><br />
    z-index: 2;<br /><br />
    height: 31px;<br /><br />
    color: #999;<br /><br />
    text-align: left;<br /><br />
    }</p><br />
    <p>

    But nothing happend

    EXAMPLE ON THIS SCREENSHOT

    t02tf5.jpg

    #80626

    Hi valentinosa,

    We’ll need to take a look at your site to inspect the form dropdowns and see exactly which css classes are taking effect on them. Could you provide a link here or if need be send a temporary admin account for me to log in and take a look with.

    You can send the information to my email at DevinVinson (at) gmail.com. Make sure to include a link to this topic so that my spam filter doesn’t grab it :)

    Regards,

    Devin

    #80628

    i fix it on IE but still shown long dropdowns on Firefox and Chrome

    http://www.livincanada.com/free-assesment/

    ( i open the site only for this matter… since it was on close mode)

    #80629

    Hi!

    Try to add following code to css/custom.css or the quick css field:

    .entry-content .ginput_container .avia_select_unify {
    width: auto !important;
    }

    Best regards,

    Peter

    #80630

    THANKS you are the DUDE!!

    one last thing…Do you know where i can do the same for the text fields, now they are also too long?

    #80631

    You can try:

    .text_input {
    width: 40%;
    }

    and change the css class a bit to target a specific field if needed.

    Regards,

    Devin

    #80632

    Hi Devin

    i add

    .text_input {

    width: 40%;

    }

    or

    .text_input {

    width: 40% !important;

    }

    and didnt work

    #80633

    Hey,

    We would like to inspect the site again but it is under maintenance when I checked.

    Regards,

    Ismael

    #80634

    i opened the site for you. thanks :)

    http://www.livincanada.com/detailed-application-form/

    #80635

    Still getting a Coming Soon Page. If you want to just create a temporary admin for me and send over the details I can log in and take a look so you don’t need to put everything up publicly.

    You can send the information to my email at DevinVinson (at) gmail.com. Make sure to include a link to this topic so that my spam filter doesn’t grab it :)

    Regards,

    Devin

    #80636

    sorry my mistake… i click in removing maintaince mode, but didnt apply, now is good.

    once again sorry

    #80637

    Hi valentinosa,

    Try to use this code:

    .medium {
    width: 23% !important;
    }

    Just adjust the width value. Hope this helps. :)

    Regards,

    Ismael

    #80638

    Thannk you so much ISMAEL! that fix the text area lengh but for some reason the dropdown menus dont work now.

    #80639

    Hi valentinosa,

    Try to replace the code I posted above with this code:

    input[type="text"].medium {
    width: 23% !important;
    }

    Hope this helps. :)

    Regards,

    Ismael

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Dropdown Options in forms too long…’ is closed to new replies.