Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #18641


    Could you tell me how come whenever I post to social media, or use bit.ly to share posts, I always get my title in the share two times?


    Here’s a picture of what I’m talking about attached.





    Your title is:

    <title>SEO Cognition | SEO | Search | Marketing  Home - SEO Cognition | SEO | Search | Marketing</title>

    If you’re using a seo tool you might want to change the default title structure. Open up header.php and replace:

    <title><?php bloginfo('name'); ?> | <?php is_home() ? bloginfo('description') : wp_title(''); ?></title>


    <title><?php wp_title(''); ?></title>


    Thank you. That’s partially fixed it. However, whenever I go to use bit.ly, or other sharing tools, it still displays like the screenshot I’ve attached.


    I’m not sure why this is doing this…


    Not sure why this happens. I checked your title and meta tags and all contain the right text string which is: “Reasons Why SEO Campaigns Fail – SEO Cognition | SEO | Search | Marketing”. Also the share buttons above the “About the author field” showed me the correct page title.


    I followed this advice.


    <title><?php bloginfo(‘name’); ?> | <?php is_home() ? bloginfo(‘description’) : wp_title(”); ?></title>


    <title><?php wp_title(”); ?></title> (also a general advice on a wordpress plug in support forum although the text to be replaced seems theme specific).

    I am using Yoast.

    It still does not work.

    The title tags are repeated and seem to be drawing from two sources (one I write in the yoast plug in and one from somewhere else).

    The best example is the contact page


    The second Indonesia Private . … . . . . . . . . should not be there.

    Basically I need to only display what is written in the Yoast SEO title box.

    By the way it has nothing to do with the rewrite Yoast option and nor am I using another SEO plug in.




    By the way – the home page is interesting. It displays non of the text that I have written in the SEO title box.


    Solved it. Strange this has been a problem for weeks and then after writing to you I crack it.



    Glad that you solved the issue :)

    Best regards,



    Thanks Peter

    A new issue has arisen now.

    It is all fine EXCEPT the home pages (English and Indonesian). IF you look the titles are not working and they are certainly not what I wrote in the SEO dashboard.

    Any advice?


    Hi cpwilson2,

    If I remember correctly, you have to actually set the home page title in yoast SEO. I don’t know if its on the home page (page) or in the plugin set up but when you change that bit in the header.php, wordpress doesn’t know what to do for a page title so it has to rely on Yoast.



Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Duplicate title tags upon posting and social media/sharing’ is closed to new replies.