Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #18540

    I can’t make the contact form to send email to the address set in the “contact & social stuff” options?

    Any idea? :(

    #99852

    p.s.: i tried the check email plugin and it works

    p.s. 2: i tried the contact form 7 plugin and it doesn0t work

    i never had problem, before, in sending email and my host (dreamhost.com) allows me to do it

    #99853

    Hi raffoz,

    I tried to check your contact form but when I clicked the link on your name, I can’t get inside, I think you have set it in Maintenance Mode (I’m just assuming because I didn’t understand the language. )

    Regards,

    Ismael

    #99854

    yes, try now :)

    sometimes (very few) email are sent, sometimes (a lot) not…

    i can’t understand why… :(

    #99855

    Hi!

    Did you try to contact your host? If Contact Form 7 doesn’t work too it’s probably a php mail() configuration issue and the host needs to check the server configuration + error logs.

    Best regards,

    Peter

    #99856

    They told me this:

    I apologize for the inconvenience.

    I just verified that e-mail is flowing from your web server and there is

    no backup of outgoing mail.

    It looks like the ‘FROM” address is not being set correctly reviewing

    your “xxx” accounts mail logs.

    Please verify that the scripts you’re using to send e-mail are using

    valid envelope headers for a ‘FROM’ address that is *hosted in our

    system*. Our updated anti-spam policies will block any outgoing messages

    that are not coming from valid addresses hosted in our system. Note that

    the “REPLY-TO” address can be an external address.

    If you have a specific example of an e-mail being sent with a valid

    ‘FROM’ address that is not making it out please give us the full

    information for that message to we can search the logs.

    If you require further assistance let us know.

    #99857

    Kriesi (and also contact form 7) just use the standard php mail function: http://php.net/manual/en/function.mail.php to send the mails. There’s no easy way for the developer to change the “from”-header information without breaking the mail function. If the theme contact form and contact form 7 don’t work for you you can try other contact forms like: Formidable. If you can’t get it to work too you might want to switch the hoster.

    #99858

    They answered me and they solved the problem.

    I apllied the solution and now everything works… :)

    I post the solution here, so maybe someone could use it… :)


    Sorry to hear about your website mail form issues. We made some policy

    changes regarding SMTP server usage recently:

    http://www.dreamhoststatus.com/2012/04/04/improvements-to-outgoing-spam-prevention-policy/

    This new policy change started in April, and is nearing phase completion

    now for all our clients.

    If you are trying to send emails from your website using an

    unauthenticated email alias (web visitor’s email) to our smtp

    servers(dreamhost),

    they will be rejected because our smtp servers don’t allow relaying for

    spam reasons(from non-dreamhost email accounts).

    For example, your webform

    shows that the FROM(web visitor email) section is what the website

    visitor inputs from your site. This is a problem because our smtp servers

    where your website is hosted, does not allow email relaying from

    unauthenticated email accounts not hosted on Dreamhost.

    Here is a copy of the last bounced message and error code:

    To: (Email address hidden if logged out)

    Subject: Test (sent by contact form at xxx)

    MIME-Version: 1.0

    Content-type: text/html; charset=utf-8

    From: (Email address hidden if logged out)

    Diagnostic-Code: smtp; 550 5.7.1 Sender domain not allowed.

    The reason why this message bounced was because your mail script or theme

    is using the webvisitor’s address instead

    of a dreamhost hosted email account, and our spam protected smtp-relay

    servers will reject this. You will need to implement

    smtp authetication into your wordpress site.

    You will need to install & configure this WordPress plugin to use these

    SMTP authentication settings:

    http://wordpress.org/extend/plugins/configure-smtp/

    If you install and use this plugin, this should correct all the

    webforms/plugins on this site to use the settings you configured.

    Google SMTP authenticated settings:

    smtp server: smtp.gmail.com

    ssl is on

    smtp authentication is on

    port 465

    user: (Email address hidden if logged out)

    pass: your password

    #99859

    Hey,

    Thank you for the solution. A lot of users can benefit from this.

    Cheers,

    Ismael

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Email from the contact form’ is closed to new replies.