Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6735

    Hi, I have embedded youtube-videos on a page. They are displayed and played correctly, but a turning “wheel” at the lower end of each video keeps on turning though loading/displaying is complete. What do I have to change?

    #55256

    Short Addition: Seems that there’s some auto-expanding of links to youtube.com and so wordpress/flashlight tries to open external links or embedded youtube-videos in a lightbox. Have to link to youtube.*de* and then the link works (e.g. appears in the same window or a new tab). Linking to youtube.*com* does not work, get a error like “Image cannot be loaded. Make sure the path is correct and image exist.”

    #55257

    Auch hier jetzt in Deutsch weiter: Besprochenes Verhalten kann nun überprüft werden unter http://www.greencard-musik.de/?page_id=277

    #55258

    Hey,

    ich denke, dieser Post: http://www.kriesi.at/support/topic/adding-extra-social-icons#post-20066 beantwortet deine Frage :)

    #55259

    Sorry, aber ich komme mit dem empfohlenen Post nicht weiter. Die Änderung von Kriesi ist im avia.js schon drin. Und das mit der nolightbox-class verstehe ich nicht: Wo muss ich das denn hinschreiben? Möchte ja auf der Seite nicht nur den Link haben, sondern das Video auch einbinden.

    #55260

    Der Video link kann wie folgt eingebunden werden:

    <a class="noLightbox" href="http://www.youtube.com/">Youtube</a>

    Statt http://www.youtube.com/ setze die Video URL ein und ersetze den Linktext. Die CSS Klasse “noLightbox” deaktiviert die Lightbox für diesen Link und das Youtube Video wird in einem Tab/Fenster geöffnet.

    #55261

    Danke für die Hilfe. Das funktioniert für den Link in der letzten Zeile der Seite “Weitere Demos …”, ok. Mir geht’s aber auch um die eingebundenen Videos auf dieser Seite – wie krieg ich denn da das “Rädchen” aus?

    #55262

    Diese werden leider vom JS Script mitumfasst. Man kann für diese Videos den Lightbox-Effekt auch deaktivieren, jedoch gilt dies dan für ALLE Youtube, Vimeo, etc. Videos. Öffne flashlight/js/avia.js und suche nach:

    autolinkElements: 'a[rel^="prettyPhoto"], a[rel^="lightbox"], a[href$=jpg], a[href$=png], a[href$=gif], a[href$=jpeg], a[href$=".mov"] , a[href$=".swf"] , a[href*="vimeo.com"] , a[href*="youtube.com"] , a[href*="screenr.com"]'

    Lösche jene Elemente heraus, welche nicht mit der Lightbox verbunden werden sollten (i.e. a[href*="youtube.com"] )

    #55263

    Danke für die Antwort, Dude. Leider funktioniert der Hinweis nicht: Auch nach Heraus-Löschen von a[href*="youtube.com"] drehen sich die Rädchen weiter. Was kann man tun?

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Embedded youtube-video keeps on loading’ is closed to new replies.