Tagged: 

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #180232

    is there a solution to enable comments on portfolio’s and pages? Can’t seem to get it working.

    all the necessary ‘allow comments’ criteria is correct and set to go, but it’s not appearing on my pages or portfolios.

    thanks

    #180501

    Hi Robert!

    If you want to show the comments on portfolio, you can edit single-portfolio.php and find this code:

     $avia_config['size'] = avia_layout_class( 'main' , false) == 'entry_without_sidebar' ? '' : 'entry_with_sidebar';
    get_template_part( 'includes/loop', 'portfolio-single' );

    Below, add this code:

    //wordpress function that loads the comments template "comments.php"
    comments_template( '/includes/comments.php');

    And edit pages.php, find this code:

    $avia_config['size'] = avia_layout_class( 'main' , false) == 'entry_without_sidebar' ? '' : 'entry_with_sidebar';
                        get_template_part( 'includes/loop', 'page' );

    Below, add the comments section again.

    //wordpress function that loads the comments template "comments.php"
    comments_template( '/includes/comments.php');

    This will only work if you’re not using the Advance Layout Editor for the pages.

    Best regards,
    Ismael

    #180918

    Hi guys,

    Can you please tell me how to DISABLE comments on all pages? i am using the facebook comment plugin and i don’t know how to remove de theme’s comment box but keep that comment counting circle , i find that usefull.

    thank you!

    #181007

    Hi Ismael,

    Thanks, that enabled comments on pages, but I’m now trying to implement Disqus as my commenting platform. It’s working (diqus) fine for my blog posts but can’t seem to get it to work on pages.

    Any suggestions?

    Thanks,
    Robert

    #181054

    Hi!

    I’m not familiar with Disqus and maybe you need to modify the theme files to use this service. The code can be found in /wp-content/themes/enfold/includes/comments.php and /wp-content/themes/enfold/includes/loop-comments.php

    Regards,
    Peter

    #181178

    Hi again,

    please, help me out with the “disable comments on pages ” problem , i really need to know how can i manage to do that, and if it is possible to keep that counting circle when using facebook comment plugin.

    thank you all!

    #181188

    Hey!

    @crdesign1 – pages do not support comments and thus you can’t remove the comment form on pages. However blog posts support comments. If you want to remove the default comment box open up single.php and delete following line

    
    
                            //wordpress function that loads the comments template "comments.php"
                            comments_template( '/includes/comments.php');
    

    The “counting circle” probably won’t work with the Facebook plugin because we use the default get_comments_number function: http://codex.wordpress.org/Template_Tags/get_comments_number which does not support Facebook comments by default. However maybe the plugin author manipulates the function output and overwrites the comments number with the facebook comments api values.

    Best regards,
    Peter

    #181194

    Thanks Dude,

    unfortunately this block’s my facebook comment too :(

    #181326

    Hi!

    @crdesign1: Can you please give us a link to the page and the post with the facebook comment section? We can try to hide the comment via CSS. Please edit a page, click on Screen Options and enable discussion. Uncheck the “Allow comments” section. I’m not sure if this is going to work but please try it.

    Cheers!
    Ismael

    #193575

    Hi, does this mean you can’t add Disqus comments to a page using the advanced layout builder?

    pages do not support comments

    #193715

    Hey!

    You can, but you’ll need to add the HTML code Disqus provides in the page.php file.

    Cheers!
    Josue

    #194496

    UPDATE: Disqus comments work on pages up until I add content using the advanced layout builder on a page. Once I do that, Disqus comments disappear. Is there a known conflict with Avia and Disqus for pages?

    • This reply was modified 7 months, 3 weeks ago by  codemode.
    #194498

    Hi!

    If you are using ALB in pages you’ll need to add that code in template-builder.php instead, around line 33 after the $content.

    Regards,
    Josue

    #194509

    Hi Josue, I think I got it to work! I added this line of code to template-builder.php:
    comments_template( '/includes/comments.php');

    Thank you for helping out!

    #194510

    You are welcome, glad we could help :)

    Regards,
    
Josue

    #196813

    Thanks Josue. I had searched for this a couple of weeks ago and this solves my problem too. The advanced editor is being used and I was really sweating not being able to use the comments in the portfolio pages.

    • This reply was modified 7 months, 2 weeks ago by  hcentral.
Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘enable comments portfolio pages’ is closed to new replies.