Viewing 29 posts - 1 through 29 (of 29 total)
  • Author
    Posts
  • #240877

    The Enfold theme is extremely slow to work with – it feels like it’s the WPML plugin that is the problem – but I don’t kn

    #240979

    Hi Kindbowebb!

    Can you please post a link to the website? What is your current host for the website? You might want upgrade your hosting plans if necessary. Increase the wordpress php memory limit to at least 128M. Refer to this link: http://dailyblogging.org/wordpress/increase-wordpress-memory-limit/

    Cheers!
    Ismael

    #241543

    Hi again Ismael,
    My website is: http://www.kindbo.com
    I have been in contact with my host one.com and there is no problem with the memory. However we did the P3 Profiler plugin and it showed that the WPML-plugin made the site way to slow. I have copied in the results of the analysis.
    It was a surprise to me that the WPML-plugin was the one causing the problems since you gave the information that Enfold is prepared for this plugin and that is also the reason why I bought it.

    Any suggestions on how to resolve this?
    Regards,
    Eva
    WordPress Plugin Profile Report
    ===========================================
    Report date: 21 mars, 2014
    Theme name: Enfold
    Pages browsed: 4
    Avg. load time: 16.6999 sec
    Number of plugins: 10
    Plugin impact: 84.01% of load time
    Avg. plugin time: 14.0291 sec
    Avg. core time: 0.2797 sec
    Avg. theme time: 2.6248 sec
    Avg. mem usage: 57.69 MB
    Avg. ticks: 13,225
    Avg. db queries : 133.25
    Margin of error : -0.2337 sec

    Plugin list:
    ===========================================
    P3 (Plugin Performance Profiler) – 0.0091 sec – 0.06% BackUpWordPress – 0.0242 sec – 0.17% Acurax Social Media Widget – 0.3510 sec – 2.50% Akismet – 0.1104 sec – 0.79% Black Studio TinyMCE Widget – 0.0070 sec – 0.05% CommentLuv – 0.0096 sec – 0.07% Google Analytics Dashboard For Wp – 0.1200 sec – 0.86% Growmap Anti Spambot Plugin – 0.0038 sec – 0.03% WPML Multilingual Cms – 13.3639 sec – 95.26% WPML String Translation – 0.0302 sec – 0.22%

    #241549

    Hi!

    WPML is supported but it isn’t something we have any part in developing so improving its performance is outside of what we can assist with through support.

    Best regards,
    Devin

    #241555

    Thanks Devin,
    I actually bought this plugin because you supported it. Since it is a premium and quite expensive plugin I actually thought that it would work. The option from you was qTranslate wich I have had problems with before on an other site. So I am very reluctant to use that one.
    Do you have any suggestions on a way forward?

    #241621

    I am trying with the plugin Polylang – hopefully that one works.

    #241626

    Hi,
    It seems like Polylang does the job and have solved several issues :) however I need help with one thing. I have o have two Front page settings for the blog, one for the Swedish one and one for the English and it seems I am only able to do one even if I change language.
    (All the other translations works as far as a I see it. I had problems with portfolio earlier but that seems to be solve.)

    Can you help out?
    Regards,
    Eva

    #241729

    Hi!

    Is this the page? http://www.kindbo.com/blogg/

    Please post the login details here and set it as a private reply. We would like to check it. We don’t usually support third party plugins, you might want to contact the plugin author.

    Cheers!
    Ismael

    #241784
    This reply has been marked as private.
    #241853

    Hey!

    Please re-uploaded the enfold\config-wpml\config.php file (use ftp). I edited the file to test if Polylang is fully compatible with Enfold but unfortunately it’s not. At the moment Enfold officially only support WPML and does not work properly with Polylang or qtranslate. If WPML does not run smoothly on your server I recommend to contact the plugin developers (they’ve a dedicated support forum) and hopefully they can provide some hints how you can improve the plugin performance (maybe by tweaking the plugin settings, etc.). If they can’t help you I recommend to try a different host provider since many other Enfold theme users also use WPML to translate their website and their websites load pretty fast (between 3-6 seconds – it depends on the size of the images, etc.).

    Cheers!
    Peter

    #241994

    Hi,
    I get thrown out when I try to upload config.php when I do it via FTP so I can’t do it that way. I have to go into the file through my web host and make the changes. What changes have you done Michael?

    • This reply was modified 4 months, 1 week ago by  Kindbowebb.
    #243207

    Hi!

    You can replace the whole contents of that file in that case or re-upload the theme files to overwrite them entirely (same thing an update does).

    Best regards,
    Devin

    #243209

    Thank you, I figured it out.
    Regards,
    Eva

    #243223

    Hey!

    I just replaced

    
    if(defined('ICL_SITEPRESS_VERSION') && defined('ICL_LANGUAGE_CODE'))
    

    with

    
    if(defined('ICL_LANGUAGE_CODE'))
    

    The reason is that polylang claims to support WPML functions (see: http://polylang.wordpress.com/documentation/documentation-for-developers/compatibility-with-the-wpml-api/ ) and I thought that it might work with Enfold out of the box because we also rely on the WPML api. But unfortunately it does not work and it seems like additional work would be required to make the plugin/theme fully compatible.

    Cheers!
    Peter

    #243235

    Thanks Peter. I have removed polylang now – I suppose you could see that? So now WPML is what I should rely on – right?
    The translations show fine now on both languages.

    However the site is still awful slow. I have run the site through https://developers.google.com/speed/pagespeed/insights/ – and many things has to be done. Do you have any suggestions how to do this besides optimizing the images? I have installed W3 Total Cache – do you think it can help out speeding up the loading time?

    Regards,
    Eva

    #244010

    WordPress speed optimization is a huge topic by itself. Your best route would be to use a caching plugin like W3, compress all over your images to their smallest possible size and/or look into a CDN for them.

    On top of that see if your hosting provider has any plans that you can upgrade to that are within your budget for the site. Ultimately its the server which has the greatest impact on how a site runs.

    #248718

    Hi Devin, Peter or Ismael
    Now I have taken away WPML-plugin and updated maximized all the slides. Then I have made two menus – the top-menu in
    English and the regular one in Swedish.

    Now the page is much faster – but I will still have to do the W3 Total Cash, CDN and other stuff to speed up the loading time.
    But there are three problems to solve and I hope you can help out;

    1. How do I allocate the English blog-posts to the English blog-page http://www.kindbo.com/blog/
    2. Can you help me put an English flag just in the end of the English top menu and a Swedish in the end of the Swedish menu?
    3. And how do I do to make the top menu as high as the regular menu?

    With these tweaks I think it could work and it feels like I don’t have to change to another theme.

    Hope for your help!
    Eva

    #249615

    Hey!

    But if you’re not using WPML how do you want to translate the website? I.e. you can’t select a different blog page without WPML and you can’t simply add language flags to the menu. With WPML our themes will support both features out of the box – without WPML you must customize the theme files for the translation plugin you want to use but we can’t assist you with the customization.

    You can increase the font seize of the secondary menu with:

    
    #top .sub_menu>ul, #top .sub_menu>ul>li {
    font-size: 13px;
    }
    

    I recommend to place the code into the quick css field or into the child theme style.css.

    Cheers!
    Peter

    #249723

    Hi Peter,
    If WPML slows down my page so incredible so I can’t use it as it seems. Even now when I have taken it away it is slow, but it shows.

    I have looked over all the images and made them as small as possible and my web host is fine. I haven’t got into the W3 Cache yet, I first wanted the page to be as good as possible before that.

    I do like the theme so I rather not abandon it. Is it really that hard to redirect the English blog posts to the English blog page – if I give them the category “English”?

    #249734

    Hi!

    Yes – the category probably won’t solve the problem. You must find a way to:

    1) Connect the translated blog page with the original blog page – otherwise the language switcher won’t work
    2) To change the blog page id based on the selected language
    3) To query all existing translations of an entry and to add the flags to the menu. Otherwise the language switcher won’t work properly.

    Actually the hard part is not the code itself but the working time which is required to study the documentation of the third party translation plugin. Every plugin comes with a different api and it requires at some working hours to rewrite the WPML based theme code for a different translation plugin. I recommend to hire a freelancer who can help you with this task. If you want to switch to another theme I strongly recommend you to ask the theme author if the theme supports another translation plugin. Most themeforest themes just support WPML and it doesn’t make sense to switch to another theme if this theme doesn’t support your translation plugin too.

    Alternatively you can try a translation plugin which doesn’t require any theme code customization at all – http://wordpress.org/plugins/multilingual-press/ – this plugin uses a separate multisite blog for each language and you can also select a different blog page, etc. for each language because each blog uses a separate option table. If you want to add the multilingual-press language switcher to the menu see http://www.kriesi.at/support/topic/multilingual-press-pro-enfold-multisite/#post-238613

    Regards,
    Peter

    #249762

    Hi,
    The WPML-team is having a look at the problem at the moment.
    Stay tuned.
    Thanks
    Eva

    #250098

    Hey!

    Alright. Please let us know and if possible share the fix if there are any. Thanks!

    Best regards,
    Ismael

    #293636

    Hey Kindbowebb,

    I think WPML isn´t your biggest problem.. You definitely need to minify all your scripts and stylesheets.. Your Frontpage needs 131 Requests, most of them are scripts and css-files. It´s important for you to combine them in 2-4 Files. You can use W3TC for it. Please take a look at this: http://tools.pingdom.com/fpt/#!/bFyxiS/http://www.kindbo.com

    There are also 17 Connection-Errors, as you can see under the page-analysis-tab..

    Look at this, too: http://developers.google.com/speed/pagespeed/insights/?url=http%3A%2F%2Fwww.kindbo.com&tab=desktop

    Your Server_Response-Time is 2,2 sec.. Normally it´s under 0,2 sec..

    Use W3TC also definitely for Page-Cache and Browser-Cache..

    There are a lot of things that going wrong with your website.. It´s better for you to hire someone with enough knowledge to make some optimizations for you. You need also some Security-Modifications, cause there are no Login-Limits or anything like this..

    Cheers

    #293642

    Hi Comitzuu,
    Thank you for taking your time with this. The site is actually much faster than it was in the beginning so the initial problems with WPML has resolved. I have also resized most of the images after that. But as you point out it is still very slow. I have previously installed W3 Total Cash but I am sorry to say that I didn’t get around to activate it since the site started to work better and then I got so much to do.
    So I will go ahead and do this tomorrow and see what other things I can do.
    The problems that I have are they due to the theme? I have not made any changes in CSS-files or in the scripts.
    I really want to learn what I do wrong. And the login-limits I have to look at too.

    Thanks

    #293645

    It isn´t a theme-problem. Enfold is a great solution with first class and clean code and great coders..

    But it isn´t an exercise of a theme to give you high-class-performance..

    It´s your turn to minify all scripts and sheets, to find well-coded plugins, to optimize your items like images eg, to use cache-solutions and good hosting-environment with powerful servers, CDN and more..

    A theme is just the face of a body and enfold is one of the best solutions you can find, but you have to do a lot to optimize WordPress (this work you need to do with every other theme, too).

    Use P3 to look which plugs are corrupt and change them with other solutions. Just stay with Plugins you definitely need, erase everything that is just a nice add-on.

    Use W3TC to minify your stylesheets (.css) in the header. Don´t combine them with scripts (.js)..

    Look in your source-code which scripts (.js) are in header-section. Try to minify them in the header-section with the default settings. If your site breaks, you have to erase the scripts from the list one by one. Every time you erased a script, reload in another browser-window your site. On this way you can find scripts that you have to exclude..
    Use the same way with body-scripts. Try to bring them before the closing body tag </body> with asynchron loading. Script-minification is the hardest thing on optimization, but it is definitely worth to spend the time..
    Test every page after you done this work. This is your first step. You have to do it again after every plugin-installation..

    Use extended disc-cache for page-cache and minify-cache. Use also browser-caching. If you´re on a shared hoster, don´t use object-cache and database-cache.

    Take also a look at Plugin Organizer and use iTheme-Security. Install smushit and use tinypng for .png´s. It´s also very important to safe jpeg´s progressive..

    Cheers

    #293663

    Hey!

    @comitzuu: Thanks for helping out! Appreciated.

    @Kindbowebb: Just to add a little bit to @comitzuu‘s response, you can do the following:

    1. Optimize all images with AI/Photoshop before uploading to server ‘save as web safe’ jpg.
    2. Once all images are on the website, optimize with www optimizer plugin twice 1hr 10mins apart.
    3. Install wp-smushit run once to remove jpeg extra data then uninstall.
    4. Use BWP minify plugin to minify scripts and stylesheets, you can also use W3 Total Cache’s minify settings but we use BWP for Enfold.
    5. Install W3 Total Cache or WP-Super cache, select all recommended settings.
    6. Logout your website, visit every page at least once to create super cache files.
    7. Join Cloudflare setup your website on their CDN, Choose options: Full CDN Optimisation save then activate purge files. Once done log out.
    8. Have a cup of coffee.
    9. Visit your site after 20 minutes or so.
    10. Don’t forget to smile.

    Best regards,
    Ismael

    #293743

    Wow! I think I start with a big smile! :) Thanks a million for all good advice comitzuu and Ismael! I am grateful that this happened to me so I get to learn and that it is not a theme problem.
    I will work both your lists and hope I can manage.

    Any suggestions for online classes to take for me to learn about optimizing?

    You made my day!
    Eva

    #294196

    Hey!

    I don’t think you need to attend classes for this subject. Just search google and you’ll find a lot of tips and tricks regarding optimization:

    https://www.google.com.ph/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=optimizing%20wordpress%20websites

    http://codex.wordpress.org/WordPress_Optimization

    Cheers!
    Ismael

    #294232

    Thanks Ismael.
    Have a great day!
    Eva

Viewing 29 posts - 1 through 29 (of 29 total)

The topic ‘Enfold extremly slow’ is closed to new replies.