Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #186779

    Hello there,

    I did a website with 9 pages (http://www.barcelonasitgesterrace.com) and two days ago I installed WPML to proceed with the set up of multilingual translations.
    Initially everything seemed to be fine, yet yesterday I realized that all the pages but the homepage give a 404 error when clicked, and I think this means the links to the pages are all broken, possibly by WPML? I haven’t done anything to the site after installing it and in the beginning it seemd to me that it worked fine.
    Now when I click on any page besides the Home I see the page gets redirected to a french version which has not been created yet, instead of remaining on the default english version and url.
    How can it be restored?
    I can provide you with access to the backend anytime. Just tell me how to give you the details.

    Thanks.

    Antonio

    PS: note for dude: what do you mean by “hijack the threads of other users…” That’s not a nice thing at all to say and the last thing I was attemping to do…

    #186810

    Hey Antonio!

    1) “hijack the threads of other users” means that you posted a new question in a thread although you’re not the thread creator. I normally accept follow up questions based on related issues but in this case (you posted the question here: http://www.kriesi.at/support/topic/enfold-wpml-wrong-default-pages-for-languages/ ) your question was completely unrelated to the topic and this is imo unfair towards the user who created the original thread because everyone has the right to get a short and specific answer to his question and doesn’t want to read bug reports of other users who experience different issues. That’s why I asked to you create a new thread.

    2) It seems like you need to flush the permalink rules. Go to Settings > Permalinks and click the save button. WordPress will then flush the rules and rewrite the htaccess file. If this doesn’t work you maybe need to modify the htaccess file manually: http://codex.wordpress.org/Using_Permalinks

    Best regards,
    Peter

    #186838

    Hey Dude!

    Thanks for the heads up and sorry for point 1. I didn’t mean to do that at all so I apologize for causing trouble if any.

    As for point 2, I did as you say but notice that it keeps the ‘post name’ ticked by default on the permalink settings structure even if mine was the custom one. I click on custom, then hit save and it keeps being on the post name option instead.

    I have no idea how to work on a htaccess file and what to do. Is that hard?

    Also, do you know if there is a way to maybe copy the pages of my original site onto another WP install on another site, so I can let’s say clone the pages that in the back end are ok, then wipe out the entire site and reinstall everything, without WPML then copy the pages again?

    Thanks. I am trying to find a way out without being a techy

    #186845
    This reply has been marked as private.
    #186886

    Meanwhile I tried deleting and rewriting the .htacces file and no results.

    However, while before installing WPML I used to have a custom permalink structure which was /%postname%/ so every page url was clearly displayed in the browser (eg: http://www.barcelonastigesterrace.com/apartment), now I notice that the permalink structure in the settings panel is set to ‘Post name’ rather than the original ‘Custom structure’ and if I want to have the custom structure, when I tick the box and hit save it goes back to ‘Post name’ rather than ‘Custom structure’. And the site doesn’t work.

    Then I tried rewriting the .htaccess file and set the permalink structure to ‘Default’ and it gets it after i hit save. This way, the site is back!
    But the url structure is now http://www.barcelonasitgesterrace.com/?page_id=2512 rather than http://www.barcelonasitgesterrace.com/apartment
    And if I hit the only page I created in a different language from the italian menu I get a 404 error page with the default Bluehost 404 page instead of the default 404 Enfold page which I used to get before.

    Am I on the right road to solving the issue? If so, how do I get back the original nice urls to display correctly? Do I need to use the WPML addon called ‘Sticky Links’ to save links from breaking again, then I can get the nice url back as they were before?

    #187203

    Hi!

    I temporarily fixed it on your server with following workaround – I switched to the standard theme (TwentyThirteen), then went to Settings > Permalinks and clicked on the “Save” button and then I switched back to the Enfold theme. Note that you mustn’t go back to the Settings > Permalinks page – otherwise WP will rewrite the flush the rules again and you need to dothe workaround again.

    It seems like WP will write and process all permalink rules in the database (I checked it with Rewrite Rules Inspector) if the standard theme is used but as soon as I try to save the permalinks with Enfold it does not process the permalinks properly because our theme adds new rewrite rules (for portfolio entries, etc.) and the higher number of rewrite rules then seems to break all permalinks on your server. I guess it’s a server configuration issue and probably you can change the number of accepted permalink rules somewhere but I’m not sure which php.ini, etc. values are affected. I marked the thread for Kriesi – maybe he knows which values need to be changed.

    Best regards,
    Peter

    #187231

    Awesome, Peter, You are a star!
    Would you suggest a WP plugin that would do a back up of the entire site, so I can install it right away, make a back up in case something happens later on?
    I am so glad you made it and want to make sure the site won’t have this kind of porblem again.

    Antonio

    #187649

    Hi!

    Yes, you can make a complete backup with: http://wordpress.org/plugins/backupwordpress/ – it’s free and works great on all of my websites.

    Regards,
    Peter

    #187705

    Thank You Peter!!!!
    Just made it!

    Awesome!

    #187761

    Hi!

    Great :)

    Regards,
    Peter

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Enfold + WPML: broken links after installation’ is closed to new replies.