Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #240351

    Hi,
    you made a great work with Enfold, keep going like this!

    I’m developing a multilanguage site in Italian, English and German
    using WPML. Main language and default is Italian.

    As you may know WPML can translate categories
    in order to show them in the correct language, and so I did.

    Now the post slider shows NO POSTS in EN and DE homepages.

    I guess the problem comes from the translated categories because
    post slider shows a category list to choose from and the categories
    in that list are not translated even if I’m working on the English homepage.
    So I have to choose a category from the Italian category list expecting
    to get the posts in English for the corresponding English category.
    Well, nothing shows up!

    Here is the default homepage in Italian, as you can see posts are showing up
    normally in “Novità ed eventi” section:

    http://www.eugea.it/wordpress/

    Here is the English version of the homepage with nothing showing up in “Our gardens” section:

    http://www.eugea.it/wordpress/?lang=en

    Here is the German homepage, this page is not translated it is a duplicate of the Italian
    homepage (WPML can duplicate pages if translation is not necessary and keep them
    in sync with the original). So this is an exact duplicate of the Italian homepage but as you
    can see nothing shows up in “Novità ed eventi” section:

    http://www.eugea.it/wordpress/?lang=de

    I hope I’ve been clear enough, if you need any other info please ask.
    I have to finish the site by monday and I’m stuck, please help!

    Alessio De Feudis

    #240567

    Hi aledef!

    Did you translate the actual categories on Posts > Categories? Please post the login details here then set it as a private reply. We would like to check it.

    Best regards,
    Ismael

    #240653
    This reply has been marked as private.
    #241114

    Hi!

    1) Maybe the language cookie is missing. Try to clear your browser cache & delete cookies and then go to the editor page to translate it. See: http://www.kriesi.at/support/topic/wpml-homepage-blog-post-not-working/#post-230549
    If this doesn’t help try to deactivate all plugins except WPML and check if the translated categories pop up. If yes a plugin conflicts with WPML and you need to activate them one by one to find the culprit. I.e. here: http://www.kriesi.at/support/topic/problems-adding-avia-button-in-spanish/ the “All-in-One Event Calendar by Timely” plugin caused a conflict.

    2) Go to WPML > Languages and deselect the ” Display the language switcher in the WP Menu” checkbox.

    Best regards,
    Peter

    #241132

    Hi Dude,
    nice nick and valuable suggestions, thank you :)

    1) I found the problem at last!
    It’s “MailChimp List Subscribe Form” plugin (v 1.4.1 at the moment) , developed by Mailchimp itself !!
    Everithing works fine when it’s inactive but I still need it to manage my subsciption forms so I guess I’ll have to find a workaround

    2) It works

    Thank you and have a nice day!
    Alessio

    • This reply was modified 7 months, 1 week ago by  aledef.
    • This reply was modified 7 months, 1 week ago by  aledef.
    • This reply was modified 7 months, 1 week ago by  aledef.
Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Enfold + WPML + Translated categories = Post slider not working properly’ is closed to new replies.