Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #20524

    Hi all,

    first, thanks for the hreat themes, very neat work!

    I’m currently struggling with the following issue:

    I created a portfolio entry, added pics and a long description text. I’d like to display only the essential part of the text and have the ‘read more’ link present, so visitors can stick to the main description without necessarily getting into tedious technical details. I seem to be unable to find the right setting for now, i’d be very thankful if you could clar that up for me.

    thanks in advance

    david

    #107999

    Hi David,

    Go to Portfolio Items and edit that specific portfolio item, then change your content editor from Visual to HTML. Then find this inside the content:

    <!--more-->

    Remove it, and the Read More should disappear showing the full content.

    Regards,

    Ismael

    #108000

    Hi Ismael,

    Thank you for the fast answer – actually it’s the other way around: i want to have the ‘read more’ link …

    I tried adding <!–more–> in the html code where i’d like the text to split, but it does not work for now.

    Could you please describe how to create that split in the text and obtain that ‘read more’ link where i want to ?

    thanks you in advance

    david

    #108001

    Hi David,

    In the screenshot: http://snag.gy/fQme0.jpg I have marked the icon that splits the text and adds the Read More. Just place the cursor in between the text that you want to split and click on the Insert More Icon. I have also marked the indicator that shows where the page is split.

    Regards,

    Ismael

    #108002

    …shame on me … thank you Ismael for the precious help, i’ll try and use my eyes next time ;)

    edit: it seems that ths doesn’t work either – i had tried to do the operation manually in the HTML code with no success, this just confirms it – might there be another parameter that conditions the use of the <!–more–> tag ?

    #108003

    Hi David,

    I’m not sure why <!–more–> is not working on your end, try to disable all your plugins.

    For more info on <!–more–>, try to check wp’s documentation: http://codex.wordpress.org/Customizing_the_Read_More

    Regards,

    Ismael

    #108004

    Hi Ismael,

    deactivated all plugins, still no luck, i ried erasing the entries and use <!–more–> in new portfolio items to no avail…

    i’m very curious about what causes this, i’m knee deep in the documentation, no idea what happens there yet.

    i’ll post back asap,

    cheers

    david

    #108005

    Hi David,

    Can you link to your portfolio page and point out one of your items that has the more tag used? I just tested it on my live install and I’m getting the correct effect.

    Just a note that this will only work on previews of the individual portfolio (ie the ajax view) and not on the individual portfolio item page itself.

    Regards,

    Devin

    #108006

    Hi Devin,

    I’ve been trying to reproduce the behaviour as shown in the Eunoia live demo on the first item (top left) ‘small item’ – i fail to differenciate portfolio item preview from portfolio item, i guess there’s some WP schooling to be done on my side.

    Nevertheless, i’d be very thankful if you could throw an eye towards this http://www.melagfrance.eu – specifically the Vakuklav41B+ product page, which is what i was working on at the time i posted the above.

    If you need an access to the wp backend please let me know

    cheers

    david

    #108007

    ok, scratch all that, i still have to figure out what setting was responsible for that strange behavior but it now does work – odd enough, but i’ll be good from here i guess :)

    thanks anyway for the always kind support,

    cheers

    david

    #108008

    Hey!

    Glad that it works now :)

    Best regards,

    Peter

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Eunoia – display only a part of the text in portfolio’ is closed to new replies.