Viewing 24 posts - 31 through 54 (of 54 total)
  • Author
    Posts
  • #102801

    A diff of the wp_router files mentioned shows the files are identical between the built-in and standalone versions of the plugin.

    #102802

    Hey!

    FYI – updated to Incarnation 1.6 and WPML 2.6.4.1, no change in behaviour.

    Regards,

    Peter

    #102805

    Hi,

    Alright, just hang in please for the updates coming shortly. Would you email me the full plugin that you are using , old computer passed away, usjahm at gmail dot com.

    Thanks,

    Nick

    #102806

    Sure; will do (though I guess I was under the mistaken impression that the updates released yesterday were the ones we were awaiting).

    Did you see my note above about the WPML guys wanting to reach out and possibly collaborate on finding a solution to the WPML 404 issue?

    #102807

    Yes, Kriesi already contacted them regarding another issue (portfolio translation) but it seems like they couldn’t help him (or at least their answers were not very helpful). But it’s obviously difficult because they don’t know our framework very well and we (on the other hand) have some problems to understand why things don’t work as expected with WPML.

    #102808

    kk… I will make my support contact there aware that there is already a connection that’s been made.

    #102809

    Hi,

    Haven’t forgotten you. I am gonna try an earlier version 2.6 of WPML that was updates before this theme was released. It was stable with few problems. If rewrites work correctly, as I expect, then I will simply start copying over line by line that’s different between the current version an 2.6 until the right line gets hit.

    Thanks,

    Nick

    #102810

    Hey Nick -

    Don’t suppose we’ve had any luck on this front, eh?

    Worse comes to worse, we’ll go live with the site with it “as-is” (with the flush rewrite rules in place, and not using the pro version of the events calendar) but just wanted to bump this up lest it fall to the second page ;-)

    -Breanne

    #102811

    Yes, still hoping for a solution on this, Nick.

    #102812

    Hi,

    I am doing my best. I am so sorry it’s taking this long.

    @mnibreanne You seem to have the version where everything is almost working. Can you clone your site as it is now. Because there is something you’ve done that I am missing.

    Thanks,

    Nick

    #102813

    Hey Nick –

    I was able to replicate the situation of my setup by following the steps as described below.

    1) Install a fresh installation of WP 3.5.1

    2) Install and activate Incarnation (latest)

    3) Set permalink structure to %postname%

    4) Import theme demo data

    TEST POINT A: everything works

    5) Install and activate WPML (latest)

    6) Configure WPML: English default, Chinese (Trad) as 2ndary language, all other options as defaults

    7) Create dummy translated pages: from Pages > All Pages click the plus sign (+) beside a page to be ‘translated’ – from the edit page, click the ‘Copy Content from English’ button, enter a page title (eg. Sermons-ZH-HANT), then publish. Do this for a few of the other pages, just to be thorough.

    TEST POINT B: navigate to any English page which you have translated; use the menu to swap to Chinese; use the menu to swap back to English; navigate to any page in English using the main menu. You will get 404 errors.

    8) Add flush_rewrite_rules(false); to functions.php

    TEST POINT C: conducting test B will no longer produce 404 errors.

    9) Install and activate The Events Calendar (free – latest)

    TEST POINT D: on the English version of the site, navigate to Sermons; click on the first sermon link (‘sermonium’) – you will get a 404; return to Sermons; click on the sermon category link (e.g. ‘Morning Sermons’) – you will get a 404

    There are different orders you can do things in, but that gets you to where I am at.

    My live setup, obviously, has a few different options and configurations set – but none functionally affect the above behaviour.

    #102814

    Hi,

    Please download this zip http://www.mediafire.com/file/tcty32jmfmwz3kj/the-events-calendar.zip , and inside is an update of the entire the-events-calendar folder inside the theme folder /config-events-calendar/

    This is the latest update so just rename the current the-events-calendar folder inside the theme, upload the folder by same name found in the zip, and deactivate The Event Calendar plugin (free) since i used the latest plugin.

    Thanks,

    Nick

    #102815

    That appears to have fixed the 404s, but upon trying to enable the PRO addon (without the standalone free version), generated two further errors:

    The first error given was: “To begin using Events Calendar PRO, please install the latest version of The Events Calendar.” In addition, going to Events > Help also says that the plugin is out of date, and references the latest version as 2.0.11. I ‘fixed’ this error by changing all instances of 2.0.9 with 2.0.11 in lib > the-events-calendar.class-.php

    The second error was: “Your version of The Events Calendar is not up-to-date with one of your The Events Calendar add-ons. Please update now.” This error is thrown on line 646 of events-calendar-pro.php

    #102816

    Hi,

    Sorry for the delay, caught a nasty bug.

    So just to make sure, without the PRO version , you have the update i posted above working with all translations and the problem now is exclusively with the pro version?

    (It’s not a trick question, if you answer yes, my question would be if premium works alone or requires the free plugin to be activated too)

    Thanks,

    Nick

    #102817

    With just your fix installed:

    • The issue described in TEST POINT D no longer occurs.
    • The WPML 404 issues still occur, as described in TEST POINT B, above. The “fix” described in TEST POINT C still serves as a workaround.

    The PRO version does not work on its own; it requires the free plugin to be activated and at the latest version in order to function.

    #102818

    Hi,

    So with point C workaround, everything works with the free version, no 404s?

    To get the pro plugin recognized, this is what should be done.

    0) make sure the pro version is deactivated.

    1) copy the folder found inside the zip I posted (the-event-calendar) and upload the folder to the wordpress plugin folder (but do not activate it. ) So now you will have it in 2 places, one in the theme folder as per previous instructions and another version in the plugin folder but not activated. only activate the pro version alone when you are finished with step 4 below.

    2) inside the pro plugin folder, (version 2.0.11) please open up events-calendar-pro.php and make the following edits there:

    add // in front of line 642 and in front of line 646. That should kill the warnings and bypass the verification while showing the pro controls.

    3) inside the theme folder /config-event-calendar/the-event-calendar/admin-views/events-meta-box.php find and delete lines 107-122 (or comment them out by adding // in front of each line

    4) line 19 of /config-event-calendar/the-event-calendar/lib/the-event-calendar.class.php should look like

    const VERSION = '2.0.11';

    Please see if it starts working

    Thanks,

    Nick

    #102819

    Re: “TEST C” – Yes. If you constantly flush the rewrite_rules, the 404s are eliminated.

    Re: TEC/TEC-PRO

    Sorry I misunderstood what you were asking when you were asking if the standalone plugin was required – the theme built-in option is sufficient, which means I did not have to complete steps 1 or 3 (or, for that matter, step 0 ;-))

    Bypassing the version check in TEC-PRO by commenting out lines 642, 644 (not in your original list), and 646 allows the pro plugin to function.

    #102820

    Hi,

    Please complete all the points since the pro plugin a few times directly looks into plugin folder for the basic plugin.

    Thanks,

    Nick

    #102821

    Can you tell me the line numbers where the plugin path is set directly by the PRO addon (not simply reading the pluginPath variable)? I did a brief search and did not find any that were hard-coded in, but may have missed some.

    #102822

    Hi,

    I don’t recall offhand, I spent too many hours looking through these things, they all are mushed in my memory. What issue are you having now? When I follow my instructions, the pro plugin worked enough to get to next step. You can do a scan with notepad++ for ‘plugin’ for the pro folder and you will see the info you wanted

    Thanks,

    Nick

    #102823

    No specific problem I’m seeing (I don’t see any problems by NOT having the standalone free plugin installed, either). More just that, every time we want to update TEC now, I’m going to have to make manual changes to hack them to compatibility, so I need to make sure I fully understand the required changes for the purpose of reproducing them down the road :-)

    #102824

    Hi,

    I am trying to get to the point where on your end everything works so a solution can be worked out that will not require endless modifications with new updates. So with the premium plugin and wpml the rewrite rules are holding up still (with your flushing fix)?

    Thanks,

    Nick

    #102825

    So far, so good :-)

    #102826

    Hi,

    Awesome! In that case I am gonna close this support request but first, I want to thank you very much, for your invaluable contribution and especially your discovery of what has become known as the Flushie Rules Postulate without which life wouldn’t be as breathtaking as it is. Thank you for your patience as well.

    Cheers!

    Nick

Viewing 24 posts - 31 through 54 (of 54 total)

The topic ‘Event Calendar (Standalone) Causes 404 on Sermon Pages’ is closed to new replies.