Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #27372


    I recently installed Flashlight on WordPress 3.6 and I’m now trying to get my portfolio in place. However, the exif data is showing up incomplete. It only shows the data of creation and copyright info, no camera exif. This is the case with both the ‘Image list attached to entry’ and ‘Flexible grid gallery’ gallery layouts. ‘Gallery Tooltips/Metadata’ is set to ‘Show tooltips with title, description and exif data’.

    A screenshot of the portfolio can be found here:

    One of the images can be found here:

    As you can see, the image does have camera exif data. I have cropped the image using Photoshop CS6.

    Any suggestions on how to solve this problem?




    Hi Tjitse,

    The exif data gets read from the image itself so if the image doesn’t have it then it wont show up.

    So for instance this image from the demo has lots of data:




    Hi Devin,

    Sorry, I notice I removed the image i posted in my previous post. Here’s another example:

    As you can see, my image also has lots of exif data. However, only the date of creation and copyright info are showing up as you can see in the screenshot in my previous post.




    If you can create a temporary admin account for me I’ll log in and take a look.

    You can send the information to my email at DevinVinson (at) Make sure to include a link to this topic so that my spam filter doesn’t grab it :)


    OK, thanks! I have sent you an email.



    Devin has been tagged on this thread. Please wait for his answer. :)




    FYI, here’s the solution I got from Devin:

    probably the exif data isn’t valid or at least wp can’t read it because Kriesi uses to fetch the exif/meta data and it worked for everyone else so far. But in this case wordpress just doesn’t return any exif/meta values and Flashlight can’t display the data if the wp_get_attachment_metadata() function fails. You can easily debug the problem – just replace

    $meta = wp_get_attachment_metadata($attachment_id, FALSE);


    $meta = wp_get_attachment_metadata($attachment_id, FALSE);


    in includes/helper-slideshow.php and you’ll see the printed array content which doesn’t contaijn any exif data. I think there’re two possible reasons

    1) The images do not contain the standard exif data or the exif data format is not supported by wp.

    2) The server configuration (gdimage library configuration) is not correct and thus the wp_get_attachment_metadata() function fails to read the exif data from the images.

    I checked 1) by uploading one of the images from the Flashlight demo, which certainly has valid exif data. The result was the same, only date of creation and copyright info. So this ruled out 1).

    I asked my hosting provider about the gdimage library and they said it is available by default. So this would also rule out 2). My hosting provider is currently stil looking into the problem.


    Just a follow up, testing things on 3.6 with Flashlight updated still gives me the same proper exif data displayed on my live server but doesn’t show it on your. So while the server shows it has the gdimage library on, it looks like it isn’t set or configured correctly.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Exif data incomplete’ is closed to new replies.