Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #11754

    Hello,

    great theme. good work. but i have a problem. when i post my page on facebook or on some other accounts i get error codes with the avia frontend – 2 variables…

    you can check this. just copy http://www.medienbrille.de in the status message of fb and you will see the problematic code errors.

    can you please help me?

    #72917

    Hello,

    It seems that the problem materialize on function-set-avia-frontend.php. Did you edit anything on this file?

    Regards,

    Ismael

    #72918

    No, i did not change anything of the code. Or is there an update for the framework which i missed?

    Here’s the error code, 841, 853 – ub seems to be the problem

    “: Undefined variable: ub in /home/www/web195/html/wp-content/themes/coalition/framework/php/function-set-avia-frontend.php on line 841Notice: Undefined variable: ub in /home/www/web195/html/wp-content/themes/coalition/framework/php/function-set-avia-frontend.php on line 853Notice: Undefined varia…”

    Perhaps it’s not a big error but it looks ugly when people see this when they are posting my website… :-(

    Do you have an idea? Thank you!

    #72919

    Hey!

    Please try to open up wp-config.php and replace:

    define('WP_DEBUG', true);

    with:

    define('WP_DEBUG', false);

    and then open up functions.php and at the very end add following line:

    error_reporting(0);

    Best regards,

    Peter

    #72920

    Hello Peter,

    i tried it now, but it does not work – there are the same errors when posting the site on facebook

    #72921

    Look here: Even Google shows all my domains including the error in the index preview. And that are two different themes i bought from kiesi! when i am searching for “undefined variable avia frontend”, i get this:

    http://www.google.de/search?client=safari&rls=en&q=undefined+variable+php_self&ie=UTF-8&oe=UTF-8&redir_esc=&ei=dp-aT5b3J4yO4gSWg_iZDw#hl=de&client=safari&rls=en&sclient=psy-ab&q=undefined+variable+avia+frontend&oq=undefined+variable+avia+frontend&aq=f&aqi=&aql=&gs_nf=1&gs_l=serp.3…5701.8148.0.8257.13.13.0.0.0.0.109.903.12j1.13.0.JZyNTFFFUgQ&pbx=1&fp=1&biw=1680&bih=914&bav=on.2,or.r_gc.r_pw.r_cp.r_qf.,cf.osb&cad=b

    medienbrille.de and galasdesign.de !

    OMG! :-/ Please help me –> Thanks a lot!

    #72922

    I’d submit a new sitemap.xml to google – they will probably reindex your website afterwards. The undefined index error messages were part of the website code and google indexed it like the standard page content. I can’t find the error message on your website anymore and google won’t index the warning messages again.

    #72923

    Hi,

    thank you. Yes, the warning message is away because i fixed it with the help of a friend. The problem is very simple. you are just defining a few browsers for your themes but there’s no elseif…

    so you could first define ub with for example Firefox:

    $ub = “Firefox”;

    OR put:

    else { $ub=”other”; }

    under the last if-command. That kills the problem. Perhaps you could change this in your versions?

    #72924

    Hey!

    I’ll mark this thread for Kriesi’s attention. He should be able to include this fix in the next update.

    Best regards,

    Peter

    #72925

    Hey!

    thanks, next framework update will include this!

    Regards,

    Kriesi

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘facebook / avia framework undefined variables’ is closed to new replies.