Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #11754


    great theme. good work. but i have a problem. when i post my page on facebook or on some other accounts i get error codes with the avia frontend – 2 variables…

    you can check this. just copy in the status message of fb and you will see the problematic code errors.

    can you please help me?



    It seems that the problem materialize on function-set-avia-frontend.php. Did you edit anything on this file?




    No, i did not change anything of the code. Or is there an update for the framework which i missed?

    Here’s the error code, 841, 853 – ub seems to be the problem

    “: Undefined variable: ub in /home/www/web195/html/wp-content/themes/coalition/framework/php/function-set-avia-frontend.php on line 841Notice: Undefined variable: ub in /home/www/web195/html/wp-content/themes/coalition/framework/php/function-set-avia-frontend.php on line 853Notice: Undefined varia…”

    Perhaps it’s not a big error but it looks ugly when people see this when they are posting my website… :-(

    Do you have an idea? Thank you!



    Please try to open up wp-config.php and replace:

    define('WP_DEBUG', true);


    define('WP_DEBUG', false);

    and then open up functions.php and at the very end add following line:


    Best regards,



    Hello Peter,

    i tried it now, but it does not work – there are the same errors when posting the site on facebook


    Look here: Even Google shows all my domains including the error in the index preview. And that are two different themes i bought from kiesi! when i am searching for “undefined variable avia frontend”, i get this:…5701.8148.0.8257.,or.r_gc.r_pw.r_cp.r_qf.,cf.osb&cad=b and !

    OMG! :-/ Please help me –> Thanks a lot!


    I’d submit a new sitemap.xml to google – they will probably reindex your website afterwards. The undefined index error messages were part of the website code and google indexed it like the standard page content. I can’t find the error message on your website anymore and google won’t index the warning messages again.



    thank you. Yes, the warning message is away because i fixed it with the help of a friend. The problem is very simple. you are just defining a few browsers for your themes but there’s no elseif…

    so you could first define ub with for example Firefox:

    $ub = “Firefox”;

    OR put:

    else { $ub=”other”; }

    under the last if-command. That kills the problem. Perhaps you could change this in your versions?



    I’ll mark this thread for Kriesi’s attention. He should be able to include this fix in the next update.

    Best regards,




    thanks, next framework update will include this!



Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘facebook / avia framework undefined variables’ is closed to new replies.