Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #4743

    Hi,

    I currently have around 70 items on my first menu in newscast. Everything was working great until I tried to add one more item to the menu and then i received this error message:

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/content/32/7975932/html/wp-includes/formatting.php on line 82

    I googled the the error and it seems that others have had the same problem with other wordpress themes, however they have been able to fix the problem. Some of these people talk about a php function which you can place in the wp-config.php called set_time_limit and just increase the limit to solve the problem. Others mention suhosin.post.max_vars and suhosin.request.max_vars.

    I do not know what this means but I need to know how to solve this problem becasue I need to finish this site which is a resource which explains the reason for so many tabs. Please help!

    #47384

    Hey,

    This is a problem with your hosting account as the server your site is on has either too fewer resources to handle your site or more likely there are far too many sites on the server. Who’s your host?

    The simple solution is to use a better host with a larger percentage of resources directed towards your site, either through switching to another provider or increasing your account limits.

    James

    #47385

    I am currently using Godaddy.com. Is their a way i can check the resources that my server is using? How would I increase my account limits?

    #47386
    #47387

    Thanks for the link, I tried to change those values however i cannot seem to find them. i think that problem is that my php.in maybe out of date or i need to change the code. it currently reads like this:

    register_globals = off

    allow_url_fopen = off

    expose_php = Off

    max_input_time = 120

    variables_order = “EGPCS”

    extension_dir = ./

    upload_tmp_dir = /tmp

    precision = 12

    SMTP = relay-hosting.secureserver.net

    url_rewriter.tags = “a=href,area=href,frame=src,input=src,form=,fieldset=”

    ; Only uncomment zend optimizer lines if your application requires Zend Optimizer support

    ;[Zend]

    ;zend_optimizer.optimization_level=15

    ;zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3

    ;zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3

    ;zend_extension=/usr/local/Zend/lib/Optimizer-3.3.3/ZendExtensionManager.so

    ;zend_extension_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3/ZendExtensionManager_TS.so

    ; — Be very careful to not to disable a function which might be needed!

    ; — Uncomment the following lines to increase the security of your PHP site.

    ;disable_functions = “highlight_file,ini_alter,ini_restore,openlog,passthru,

    ; phpinfo, exec, system, dl, fsockopen, set_time_limit,

    ; popen, proc_open, proc_nice,shell_exec,show_source,symlink”

    I have tried playing with the max_input_line by increasing it however I doesn’t seem to work. Do you think that I need to upgrade my php.in file? and if i do where can I go to get one becasue i have no experiance with coding? Thank you and I appreciate your support in helping to try and figure this problem out.

    #47388

    Please try to contact Godaddy and ask them what’s the best way to increase the execution time. The worst case would be that the hoster doesn’t allow any modification to the execution time variable.

    #47389

    I will contact GoDaddy, and post any resolution here. Thanks for your help

    #47390

    Hope they can help you :)

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Fatal Error Maximum Execution time of 30 Seconds exceeded’ is closed to new replies.