Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #19644

    Hello,

    On my blog posts, I would just like to have a small image appear as the featured image to the left or right of the text. When I set a featured image to the post, it’s blown up huge and shows up in the slideshow area of the site. I’m aware of the image size options, but the image still shows up very large and in the slideshow area as opposed to next to the post. How can I make this work?

    #104435

    Hi,

    you can use the default image/media embed feature to insert an image into your text content. Go to the post/page editor page and click on the media button in the top left corner of the text editor. Then select an image (just click on it) and hit the blue “insert into post” button. You can also change the alignment, image description, etc.

    #104436

    I understand that, but then none of my posts have featured images for the sidebar widgets or “related posts” section at the bottom of the post. Is there any other suggestion?

    #104437

    You can use a workaround i this case. Open up wp-contentthemesrepleteincludeshelper-slideshow.php and replace:

    if($this->slideshow_poster == 'poster')
    {
    if(avia_is_overview())
    {
    if(is_array($this->slides)) { $this->slides = array_slice($this->slides, 0, 1); $this->type = $this->defaultSlider; }
    }
    else
    {
    if(is_array($this->slides) && isset($this->slides[1])) $this->slides = array_slice($this->slides, 1, count($this->slides));
    }
    }

    with

    if($this->slideshow_poster == 'poster')
    {
    if(avia_is_overview())
    {
    if(is_array($this->slides)) { $this->slides = array_slice($this->slides, 0, 1); $this->type = $this->defaultSlider; }
    }
    else
    {
    if(count($this->slides) > 1)
    {
    if(is_array($this->slides) && isset($this->slides[1])) $this->slides = array_slice($this->slides, 1, count($this->slides));
    }
    else
    {
    $this->slides = array();
    }
    }
    }

    Then go to Theme Options > Layout & Settings and search for the “Slideshow behavior on overview pages” dropdown. Select the last option (“Display only single image on overview pages and all slideshow images except the first one on single entries”). By going this way you won’t see a slideshow if you just add one image to an entry.

    #104438

    Alright, I tried this and it solves the problem for the posts themselves, but my homepage still displays the huge images:

    http://squaresound.wpengine.com

    Also, is there any way to just not display the sub-category thumbnails at all? I know I can just remove the category thumbnail, but then there are no thumbnail images showing on the category pages.

    http://squaresound.wpengine.com/catalog/anime-sheet-music/fullmetal-alchemist/

    It seems like some strange design decisions were made with this theme.

    #104439

    I fixed the second issue by just hiding subcategories altogether. It works for my particular setup. Now I’m just concerned about the first issue and I should be good. Thanks.

    #104440

    Hi tjmaxwell,

    Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #top.blog .template-blog .slideshow_container {
    display: none;
    }

    In the woo commerce settings, you choose if you want to show category thumbnails or not in your normal shop page. The same with sub-categories on the other pages. It isn’t a theme design decisions its just part of the plugin to give users more flexibility.

    Regards,

    Devin

    #104441

    Thanks Devin.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Featured Image Issues’ is closed to new replies.