Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17896

    Hi,

    I would have a problem.

    I created a page, assigned the blog to it, and started writing articles.

    In Styling i chose the option to show the first slideshow image as a preview only on the overview pages, and showing the complete slider with all of the images except the first one in the full post.

    Now, I tested this for the portfolio overview page – single posts and works wonder.

    But when i come to the blog single posts, the image which is supposed to disapear is there.

    In the overview pages i get all of the images in the slider unless i set the post format to Standard.

    Am I doing something wrong?

    If you would need to see the actual problem on the website I can create some posts to show what i mean (since for now I left only a single post with one imae in the slideshow).

    Thanks a lot for your help,

    Lorenzo

    #97400

    Hey Lorenzo,

    I just did a quick test on my live install and am getting the same issue. I’ll tag Kriesi on the topic so that he is aware of it and can address it in a theme update.

    Regards,

    Devin

    #97401

    Hi Devin,

    Thank you for your quick reply and for your help!

    For the time being, is there anything you can think of to go around it?

    I also noticed that in the image behaviour settings you can choose from: big image/video, small image/video…. but all the small options place the image either left or right leaving space for a caption… is there a way to center it while keeping it small (since the image automatically resizes)? Or must I upload a picture of the suggested h/w and having the content i want to display centered already? ( i mean creating an image leaving blank spaces on the sides and having the actual content centered)

    For the blog issue i was thinking, could i somehow use the Custom Post Templates plugin to create a different single.php (with another name of course) to load instead of the default one, where i would DISABLE the slideshow completely? since to render the page the code calls in loop-index.php i wouldn’t really know how to do it… would it be enough to just paste the whole loop-index.php in place of the function calling it in and then go erase the parts where the slide is created/called in?

    And then save it with another name and choosing it as the post type through the plugin, ovverriding the normal single-blog.php?

    I could then supply to the lack of a slider creating an in-content slider (through external plugins or other means) placing the new slider just under the title could be an idea (and then using the pos-excerpt to make sure it doesn’t show on overview pages).

    I am not that good in coding… what would you suggest? I don’t necessarily need that big slider for the single-blog… actually i would like to remove it. Does what i wrote up there makes sense? I’ll try working with it but again any suggestions are appreciated.

    I’ll update the post if i find any way around the issue,

    Thanks for the help and sorry for mispellinsg and such, English is not my first language :)

    Cheers, and thanks again,

    Lorenzo

    #97402

    I can’t seem to find what function calls the slideshow in… any help?

    Nevermind, i found this CSS that hides the slideshow in single-blog pages

    #top.single .slideshow {
    display: none !important;
    }

    #97403

    Hi Lorenzo,

    Yes, that will do it though it on the single pages. It is probably the best solution for the time being as the slideshow is pretty big complicated class and I’m not comfortable modifying it since so many theme functions rely on it.

    Regards,

    Devin

    #97404

    this is intended behavior, the big slideshows will always display all images. might be a little confusing. If you want to you can disable that behavior by removing line 188 in includes/helper-slidehsow.php were the option is set to default


    $this->modify_slide_poster('default');

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Featured Image on Blog – Slideshow options not working!’ is closed to new replies.