Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5366

    Hey guys,

    I’ve just noticed that the featured media that I upload, including image etc, do NOT show up in the RSS feed. Now, I’ve tried searching for this through the various setting in my admin panel and I cannot seem to make it work. Considering I have entire posts that are JUST the featured media, them not showing up in the RSS feed is a HUGE no for me.

    Is there currently a solution to this? Or CAN there be one?

    Thanks!

    #49890

    Hey,

    you can use following code in functions.php:

    // THIS INCLUDES THE THUMBNAIL IN OUR RSS FEED
    add_filter( 'the_excerpt_rss', 'inoplugs_insertThumbnailRSS' );
    add_filter( 'the_content_feed', 'inoplugs_insertThumbnailRSS' );
    function inoplugs_insertThumbnailRSS( $content ) {

    global $post;
    $slides = avia_post_meta($post->post_id, 'slideshow');
    if ($slides){
    $postimage = avia_image_by_id($slides[0]['slideshow_image'],'thumbnail');
    $content = '<div>' . $postimage . '</div>' . $content;

    return $content;
    }
    }

    You need to clear the browser cache to see any feed changes.

    #49891

    Thanks for the reply. I added that into the functions.php like so and cleared my cache and I still don’t see any of the featured images in the RSS feed. >.<

    P.S. Another quick question I promise, last one. hahah The combo widget that came with the theme. Is there a way to edit that? Where can I find that ?

    Thanks!

    #49892

    1) I tested the code on two servers (localhost and online) and it worked with Shoutbox. Maybe try to use other browsers so you can make sure that it’s not cache related. If you’re using a wp cache plugin (SuperCache, W3 Total cache, etc.) try to clear all caches too (because some of them cache feeds). If this doesn’t help maybe a plugin filters the feed. Just to be sure :) – I refer to the functions.php file in the theme folder and not in the wordpress main directory.

    2) You can change the code in shoutboxframeworkphpclass-framework-widgets.php after following line:

    class avia_combo_widget extends WP_Widget {

    #49893

    Okay, I figured out why I don’t see it. So the image shows up in my regular wordpress feed, so http://www.heynadine.com/feed/ . But i usually redirect the feed to http://feeds2.feedburner.com/heynadine and then the featured images do not show up there. Is there a way to make them show up there? Maybe someone with feedburner knowledge knows more :/

    Also, I noticed that the featured image is displaying as a static size, in your instance, you set it as the thumbnail, so ALL the featured images show up as a tiny thumbnail in the RSS. However, the specific size for each post varies, and I actually set the featured image to have a photo for the preview then the click through to an embedded video. I need to get that embedded video into the RSS feed.

    Thanks,

    #49894

    To be honest I can’t help you with both questions.

    1) I don’t know how to fetch/display feedburner feeds – hopefully another user knows more

    2) It’s not easily possible because:

    a) I’m not sure if flash objects can be part of a feed – very likely only the url can be part of it.

    b) This needs some custom coding (you need to check the file type, etc.) which is beyond the scope of this support forum.

    3) You can change the thumbnail size to a different one. Change ‘thumbnail’ in the code above to ‘page’ or ‘fullsize’ to display bigger thumbs.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Featured Media RSS Feeds’ is closed to new replies.