Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #167615

    Hi,

    We are using Propulsion. Since the latest WP update (so it seems), the first image of the uploaded featured media is not showing in the product page. It seems like this is going on on all product pages. It HAS worked, so images have been added the correct way.

    So, for example, if 3 images are added to the featured media, we only see 2 on the page. We have updated Propulsion to the latest version and this did not help.

    We discovered it by ‘accident’ because it’s clear on this page:

    http://www.cncpt13.com/shop/frank-willems/plus-de-madam-rubens-long-chair/

    The image of the chair itself is not visible. When we change the order of the images, it’s still the top image which is not showing.

    Please advise. Thank you.

    Best regards.
    Carsten

    #168041

    Hi twelvetrains!

    Please open up wp-content\themes\propulsion\config-woocommerce\woocommerce-mod.js and delete

    
                    if (index != 0){
                        container.find('.slideshow li a:eq(0)').css( "display", "none" );
                    }
    

    and

    
    
                    if (index != 0){
                        setTimeout(function(){
                            container.find('.slideshow li a:eq(0)').css( "display", "block" );
                        }, 1500);
                    }
    

    – does this code mod fix the issue?

    Best regards,
    Peter

    #168710

    Hi Peter,

    Thanks for your quick reply. I just removed those lines as you suggested but the first image is still not shown.

    So I’m afraid that was not the solution. Looking forward to your follow up. Thanks.

    Best regards,
    Carsten

    #169158

    Hi!

    I just noticed that the slideshow just contains two slides and it’s not a js issue – you can revert the change I suggested in my last post.
    Maybe you activated the “remove first slide” option? Go to Propulsion > Layout & Settings and search for the “Slideshow behavior on overview pages” option. Make sure that the “Display default slideshow on overview pages and on single entries” option is selected.

    Regards,
    Peter

    #169247

    Hi Peter,

    Yes, that setting was the ‘problem’, products are now showing all images. I’m sorry about this, I was sure I had run through all settings.

    Thank you for your help!

    Best regards,
    Carsten

    #169310

    Hey!

    Great, glad it works now :)

    Cheers!
    Peter

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘First image of each product is not showing’ is closed to new replies.