Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #257407

    Hi there,

    Have recently updated from 1.6 to latest version of Flagship and WP 3.9. – after updating to Flagship the custom header background image I have set for the home page is no longer showing/overriding the default header background.

    I will add links to URLs in private message.

    Tested in all browsers and turned off all plugins.

    Will continue to work on a fix. Look forward to your reply>

    • This topic was modified 6 months, 4 weeks ago by  loudcow.
    #257412
    This reply has been marked as private.
    #257652

    Hi!

    Please add following code to Quick CSS in Flagship theme options under Styling tab

    #apply_header_bg {
    background-image: url(http://yourdomain.com/wp-content/uploads/2013/01/Hunter-Jacobs-Recruitment.jpg);
    background-position: top center;
    background-attachment: scroll;
    background-repeat: no-repeat;
    -webkit-background-size: cover;
    -moz-background-size: cover;
    -o-background-size: cover;
    background-size: cover;
    }

    P.S.: You should change only your domain in background-image
    Cheers!
    Yigit

    #257949

    Thanks so much Yigit. That works however it applies the background to all pages – the home page and internal pages.

    The demo site, like the present live site, has a different background for the home page BUT the internal pages are set with the default that I’ve chosen in the ‘styling’ settings in Theme Options panel. There is an option to change to a custom background PER page (underneath slider options per page) but when I try to do this for the home page it won’t read the change.

    Best regards – Catie

    #258027

    Hey Catie!

    Try changing the code to:

    .home #apply_header_bg {
    background-image: url(http://yourdomain.com/wp-content/uploads/2013/01/Hunter-Jacobs-Recruitment.jpg);
    background-position: top center;
    background-attachment: scroll;
    background-repeat: no-repeat;
    -webkit-background-size: cover;
    -moz-background-size: cover;
    -o-background-size: cover;
    background-size: cover;
    }

    Cheers!
    Josue

    #258053

    Yep – that did the trick. Thank you! All back to normal now:) I assume this will be fixed in later updates.

    Appreciate the quick turnaround time here. Have an awesome day! Catie

    #258057

    You are welcome Catie, glad we could help :)

    Regards,
    Josue

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Flagship – Custom Header Background Image not showing – Only Default Header’ is closed to new replies.