Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #176576

    The tabs feature used in the Visual Composer plugin, breaks when used on the Flagship framework.

    Symptoms include:

    • Ugly tab hash id appearing the address bar.
    • Page jumps each time a tab is clicked.

    The problem seems to be something to do with the Flagship framework using a deprecated jQuery code?

    Flagship Debug Error:

    [18:25:31.935] Use of getPreventDefault() is deprecated. Use defaultPrevented instead. @ http://46.32.253.31/~isite/cms/wp-includes/js/jquery/jquery.js?ver=1.10.2:4

    Apart from a Flagship update containing a fix, does anyone have a fix for this?

    Regards,

    Mark

    #176583

    Hey msfirth!

    Are you using the latest version of flagship (v1.6)? If not please update your theme.

    Cheers!
    Peter

    #176591

    Yes. I’m using version Version 1.6. I updated recently.

    Am I right in saying, that this version of Flagship uses jQuery 1.102, migrating to version 1.21 ?

    /wp-includes/js/jquery/jquery.js?ver=1.10.2
    wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1

    Thanks,

    Mark

    #176943

    Hi!

    Yes, Flagship 1.6 is compatible with 1.10.x and uses the default jquery script which is bundled with wp3.6

    Best regards,
    Peter

    #176945

    Hi!

    If you want to deactivate the smooth scroll feature you can deactivate the “smoothscroll” function. Open up flagship/js/avia.js and delete

    
    	if(jQuery.fn.avia_smoothscroll)
    	jQuery('a[href*=#]').avia_smoothscroll();
    

    Cheers!
    Peter

    #177264

    Worked a treat. Many thanks for this.

    Regards,

    Mark :)

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Flagship Not Compatible with Visual Composer’ is closed to new replies.