Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #179316

    Hi guys,

    I have flashlight with WPML. The languages are English, Spanish, French, Russian and Catalan pages and portofolio translations. I changed the permalinks in each language of each portofolio item, and i saved permalinks in each language through Settins>permalinks> Save.
    The result is only some languages are working, other shows me 404 Error page, and if i save permalinks of one language that doesn´t work after Settins>permalinks> Save it works but the other doesn´t do it.

    Any idea?

    Thanks!

    #179391

    Hi regularsize!

    It could be a special characters issue, in which languages the permalinks aren’t working?

    Cheers!
    Josue

    #179776

    Hi Josue!
    It’s not a character issue. If Spanish portofolios permalink is not working, i go to Settings>permalinks> Save after that Spanish portofolios permalinks works well, but the other languages permalinks aren’t working…

    When I created the first portolios items in spanish, i used later duplicate function in every portofolio item for create the translations. That way i can translate later and i have the images added at one clic (without adding one by one in each language portofolio item). When i do this i have all portofolio items in all languages… but all of this points to same URL and if I change the URL in every portolio and save later… boom it doesn’t work.

    Maybe have I to translate without duplicate mode? creating each portofolio item in each language adding each photo one by one?

    Cheers!
    regularsize

    #180568

    Hi!

    Yes, personally I recommend to click the “Translate independently” button to deactivate the “Duplication mode”. You can use it to copy the data from the original post to the translated post but then you should translate them independently.

    Regards,
    Peter

    #190200

    In relation with portofolio and permalinks, i don’t know why but it doesn’t work. When i click portofolio link it shows all portofolio items, but when i click an item appears 404 Error page. If i go to Settings>permalinks>save i solve the 404 Error page, but after a while again 404 Error page when i pick a portofolio Item.

    I don’t know how to solve this issue!

    Cheers.

    #190869

    Hey!

    Another users reported that the avia_flush_rewrites caused a similar problem on his server. Try to deactivate this function – open up /wp-content/themes/flashlight/framework/php/function-set-avia-backend.php and replace

    
    add_action('wp_loaded', 'avia_flush_rewrites');
    

    with

    
    //add_action('wp_loaded', 'avia_flush_rewrites');
    

    Afterwards go to the “Settings>Permalinks” page and save the settings.

    Cheers!
    Peter

    #190913

    Thanks Peter!

    Cheers!
    Beto

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Flashligt Portofolio with wpml and permalinks not working’ is closed to new replies.