Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17698

    Hi

    On one of my pages I am using the Flexible Grid Gallery / Masonry layout via the gallery options, so that I can have a wide page of content.

    I have also loaded a specific image via that gallery as my page background. The problem is that a thumbnail of that background image gets loaded at the bottom of the page by default if you choose the Flexible Grid Gallery option. Is there a way to force the gallery not to do this on this page?

    http://claytonbhanks.com/short-content/

    Thanks

    #96491

    Hi circusvoltaire,

    That doesn’t sound like default behavior. As far as I know it shouldn’t do anything but load in a gallery. How exactly do you have the page setup? Do you have images loaded into the page itself or is it assigned a portfolio from the Theme Options> Portfolio?

    Regards,

    Devin

    #96492

    Hi thanks

    In the main edit window of the page edit screen I have just embedded some videos and put some text.

    The one image that is showing up on the bottom left of the main content container on the front end, is the one and only background image on this page that I uploaded via the Gallery Options below in the Image Gallery section.

    Then I have

    Gallery Layout: Flexible Grid Gallery

    Enforce Default Background: Use this gallery as a background

    Background Gallery controlls: Hide controls

    Gallery Autorotation: no autorotation

    Background Gallery Transition: Fade

    Gallery Tooltips/Metadata: Sho no tooltips

    Do you want to display: Display no pattern overlay

    Image Cropping/resizing: Images should be scaled to fit

    Instant Background Gallery: Display sidebar and content on page load

    Under Layout Options for the page I have

    Choose a Page Layout: Default Layout (content+small title)

    Do you want to display a sidebar? : No right sidebar

    #96493

    I see now. Whats happening is you aren’t actually using the flexible grid layout at all for your main content. Instead, you are just using a normal page’s visual editor content and when you add the one single image into the gallery it shows up as a flexible grid would if you had more images.

    You can get rid of that single image by adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #top.page-id-13 .masonry-content-area.masonry {
    display: none;
    }

    Its a bit of a hack, but if you have the layout how you want it as is, no reason to go and re-do everything.

    Regards,

    Devin

    #96494

    Thanks that got rid of the image :)

    – Yes I did that because the content I want to show is videos not images. Is there a way to use the flexible grid layout properly for videos? If not what I have works :) thanks

    #96495

    No I don’t believe there is so this would be your best option.

    Regards,

    Devin

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Flexible Grid Gallery / Masonry – Background Image Hack’ is closed to new replies.