Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #9804

    I wrote a post on my blog that contains a More tag in the middle. When I click the Read More link in that post on my home page, it takes me to the single post, but fails to jump down to the More tag. From what I’ve been reading on the WordPress support forums, this is most likely an issue with the theme.

    In addition to this, custom More messages are not being applied. For example, <!–more Custom message–> just displays “Read more” instead of “Custom message”.

    Could you shed any light on the above two issues?

    #65905

    Anyone?

    #65906

    Hey!

    In template blog.php there is a function call for the content at line 85

    the_content(‘Read more’);

    you probably have to delete the hard coded read more and make it read

    the_content();

    to make custom messages work.

    As for the read more jump link: not sure why this happens for you: as you can see in the theme demos blog it works they way it is intended to work: http://www.kriesi.at/demos/display/blog/

    maybe there is a plugin that alters the read more option?

    #65907

    Thanks, but I forgot to mention that this is happening in one of the content boxes on the home page (Mainpage column 1, which is displaying a Post). The Read more behaviour is being affected by line 140 in wp-contentthemesdisplayframeworkclasseskclass_display_box.php:

    echo '<a href="'.get_permalink().'">Read more</a>';

    How do I make it use the standard More behaviour?

    (Edit: code formatting)

    #65908

    Hey!

    Try to replace following code in kclass_display_box.php:

    the_content('');
    echo '<a href="'.get_permalink().'" class="more-link">Read more</a>';

    with:

    the_content('Read more');

    Regards,

    Peter

    #65909

    Thank you! I replaced the lines you suggested with:

    the_content();

    and now it behaves exactly as expected. Note that I did not pass a parameter to the_content() so that it will use the custom message from my more tag (as described in my first post). I also had to edit the more-link style in wp-contentthemesdisplaycssstyle*.css as follows:

    .more-link{
    background:transparent url(../images/skin3/bullet_white.png) no-repeat scroll right 15px; /* Unchanged */
    padding-right: 8px; /* Added this to keep the bullet from touching the text. */
    display: inline; /* Added this so it doesn't wrap the text like the default block style. */
    }

    Without the above css modification, the custom more text was displaying in block format and wrapping oddly.

    #65910

    Hey ifligus,

    Glad thats working for you and a big thanks for adding the custom css you added to make it work even better! Really helps out everyone when that is done :)

    Regards,

    Devin

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Following the More tag stays at top of page’ is closed to new replies.