Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #15058

    Hi guys,

    I’m using Propulsion 1.5, I noticed some strange behaviour in the loading of fonts. Texts and menus on my site recently look bloated and bold whereas it should look more refined. It’s most clear when using Safari 6.0 on my homepage (the url is amsterdamwinds.nl). When the Adaptivia slider rotates to the next images, you shortly get to see what the font should look like. Also the menu on top partly switches back to it’s original state in regular font size.

    I had a look at the live Propulsion demo and it has the same kind of weird behaviour. On the homepage all fonts look ok, but once you click on any of the menu items all texts go bold.

    In Chrome you get to see this weird behaviour when using the drop down menu, it quickly switches from regular to bold font.

    Don’t know what causes this. Somehow it looks like the wrong fonts are pulled in. How can I get things back to ‘normal’?

    Thanks for looking into this.

    #86025

    Hello,

    Are you using Terminal Dosis as your font? I checked the site on Firefox, Chrome and Safari and they seem to render the regular font, no bold. Let me tag the rest of the support team, see if they can catch the strange behaviour.

    Regards,

    Ismael

    #86026

    Yes I’m using Terminal Dosis. Hope to hear soon, thank you.

    #86027

    Hi,

    Your http://amsterdamwinds.nl/adamwnds2012/wp-content/plugins/comprehensive-google-map-plugin is the culprit. It refuses to work with the version of jquery used in possibly jetpack plugin you are using or maybe some kind of a link checking plugin? Hard to tell, but there is a very old jquery someplace in one of the plugins. Try to deactivate the plugins and see if everything becomes normal.

    Thanks,

    Nick

    #86028

    Thanks Nick, I tried switching off all plugins but the issue remains.

    Strangest thing is, if I use my iPad3 and have a look at http://www.kriesi.at/themedemo/?theme=propulsion I notice the same thing happening in the demo which would suggest it’s something not just local to my site or machine. In the Propulsion demo home-state everything is normal (menu font weights etc.) but once you click on a menu item, you can see the font weight in the menu change.

    Maybe it’s something with Safari not rendering the right font with Retina displays in mind? I did not have this issue before upgrading to Mountain Lion…

    #86029

    Hi sungoshine,

    Thanks for letting us know. I’m going to tag Kriesi to this just so he can read the issue.

    Regards,

    Mya

    #86030

    Sungoshine,

    Here is just a part of what’s showing at the bottom of your pages. There is more.

    <param id='errors' name='errors' value='{ "oldJquery" : "ATTENTION! (by Comprehensive Google Map Plugin)nnYour blog/site theme or one of your plugins uses jQuery javascript library which is older than the version 1.3.0.nThe Comprehensive Google Map plugin will not work with such outdated jQuery version.nnThe minimum jQuery requirement for Comprehensive Google Map plugin is version 1.3.0. Apologies for the inconvenience..",
    "badAddresses" : "<b>ATTENTION</b>! (by Comprehensive Google Map Plugin)<br /><br />Google found the following address(es) as NON-geographic and could not find them:<br /><br />[REPLACE]<br />Consider revising the address(es). Did you make a mistake when creating marker locations or did not provide a full geo-address? Alternatively use Google web to validate the address(es)",
    "kml" : "<b>ATTENTION</b>! (by Comprehensive Google Map Plugin)<br /><br />Dear blog/website owner,<br />Google returned the following error when trying to load KML file:<br /><br />[MSG] ([STATUS])",
    "kmlDocInvalid" : "The KML file is not a valid KML, KMZ or GeoRSS document.",
    "kmlFetchError" : "The KML file could not be fetched.",
    "kmlLimits" : "The KML file exceeds the feature limits of KmlLayer.",
    "kmlNotFound" : "The KML file could not be found. Most likely it is an invalid URL, or the document is not publicly available.",
    "kmlRequestInvalid" : "The KmlLayer is invalid.",
    "kmlTimedOut" : "The KML file could not be loaded within a reasonable amount of time.",
    "kmlTooLarge" : "The KML file exceeds the file size limits of KmlLayer.",
    "kmlUnknown" : "The KML file failed to load for an unknown reason.",
    "msgApiV2" : "<b>ATTENTION</b>! (by Comprehensive Google Map Plugin)<br /><br />Dear blog/website owner,<br />It looks like your webpage has reference to the older Google API v2, in addition to the API v3 used by Comprehensive Google Map! An example of plugin using the older API v2, can be jquery.gmap plugin.<br /><br />Please disable conflicting plugin(s). In the meanwhile, map generation is aborted!",
    "msgMissingMarkers" : "<b>ATTENTION</b>! (by Comprehensive Google Map Plugin)<br /><br />Dear blog/website owner,<br />You did not specify any marker locations for the Google map! Please check the following when adding marker locations:<br /><b>[a]</b> In the shortcode builder, did you add location(s) and clicked the Add button before generating shortcode?<br /><b></b> In the widget, did you add location(s) and clicked Add button before clicking Save?<br /><br />Please revisit and reconfigure your widget or shortcode configuration. The map requires at least one marker location to be added..",
    "msgNoGoogle" : "<b>ATTENTION</b>!(by Comprehensive Google Map Plugin)<br /><br />Dear blog/website owner,<br />It looks like Google map API could not be reached. Map generation was aborted!<br /><br />Please check that Google API script was loaded in the HTML source of your web page"}
    <param id='errors' name='errors' value='{ "oldJquery" : "ATTENTION! (by Comprehensive Google Map Plugin)nnYour blog/site theme or one of your plugins uses jQuery javascript library which is older than the version 1.3.0.nThe Comprehensive Google Map plugin will not work with such outdated jQuery version.nnThe minimum jQuery requirement for Comprehensive Google Map plugin is version 1.3.0. Apologies for the inconvenience..",
    "badAddresses" : "<b>ATTENTION</b>! (by Comprehensive Google Map Plugin)<br /><br />Google found the following address(es) as NON-geographic and could not find them:<br /><br />[REPLACE]<br />Consider revising the address(es). Did you make a mistake when creating marker locations or did not provide a full geo-address? Alternatively use Google web to validate the address(es)",
    "kml" : "<b>ATTENTION</b>! (by Comprehensive Google Map Plugin)<br /><br />Dear blog/website owner,<br />Google returned the following error when trying to load KML file:<br /><br />[MSG] ([STATUS])",
    "kmlDocInvalid" : "The KML file is not a valid KML, KMZ or GeoRSS document.",
    "kmlFetchError" : "The KML file could not be fetched.",
    "kmlLimits" : "The KML file exceeds the feature limits of KmlLayer.",
    "kmlNotFound" : "The KML file could not be found. Most likely it is an invalid URL, or the document is not publicly available.",
    "kmlRequestInvalid" : "The KmlLayer is invalid.",
    "kmlTimedOut" : "The KML file could not be loaded within a reasonable amount of time.",
    "kmlTooLarge" : "The KML file exceeds the file size limits of KmlLayer.",
    "kmlUnknown" : "The KML file failed to load for an unknown reason.",
    "msgApiV2" : "<b>ATTENTION</b>! (by Comprehensive Google Map Plugin)<br /><br />Dear blog/website owner,<br />It looks like your webpage has reference to the older Google API v2, in addition to the API v3 used by Comprehensive Google Map! An example of plugin using the older API v2, can be jquery.gmap plugin.<br /><br />Please disable conflicting plugin(s). In the meanwhile, map generation is aborted!",
    "msgMissingMarkers" : "<b>ATTENTION</b>! (by Comprehensive Google Map Plugin)<br /><br />Dear blog/website owner,<br />You did not specify any marker locations for the Google map! Please check the following when adding marker locations:<br /><b>[a]</b> In the shortcode builder, did you add location(s) and clicked the Add button before generating shortcode?<br /><b>
    </b> In the widget, did you add location(s) and clicked Add button before clicking Save?<br /><br />Please revisit and reconfigure your widget or shortcode configuration. The map requires at least one marker location to be added..",
    "msgNoGoogle" : "<b>ATTENTION</b>!(by Comprehensive Google Map Plugin)<br /><br />Dear blog/website owner,<br />It looks like Google map API could not be reached. Map generation was aborted!<br /><br />Please check that Google API script was loaded in the HTML source of your web page"}

    It is difficult to pinpoint a relatively small font display problem when there is a much bigger unresolved issue showing errors on the bottom of every page. Please read the various errors above to get an idea of the magnitude.

    Thanks,

    Nick

    #86031

    Hi,

    But the good news is that I did manage to grab a comparison screen shot of the font discrepancy. http://108.171.183.16/fonts.png Is this the issue you were referring to? its two versions of how the fonts come out. I am testing what triggers this behavior, and indeed the browser you recommended best illustrates it. Thank you for pointing it out. Once I get the font fixed, we will figure out a way to get you back at 100%, no worries!

    Thanks,

    Nick

    #86032

    Hello Nick,

    Thank you very much for looking into this. The screenshot you made is from a windows machine I guess, but it looks like the thing I’m running into. I made a screenshot/video of it as well to make it even more clear what’s happening: https://vimeo.com/47089702

    Watch the menu change with the slider and within the slider the text is bold then shortly switches to lighter version as well. At the end you can see the same thing happening in the menu of Kriesi’s Demo site. Although not as obvious as in mine you can see that in home state everything is ‘normal’ but once you click on the menu items the bolder font is used in the menu (note: all in Safari 6).

    Meanwhile there’s some work for me cut out to do Plugin-wise I guess ;) Oh the joy!

    Cheers.

    #86033

    Hi,

    Your video is private.

    Yes, image is from a windows machine but I used the Apple browser. I think a member of the support team who owns an Apple would be better equipped for exploring this since its very hard to catch on a Windows machine.

    Thanks,

    Nick

    #86034

    sorry, changed the settings of the video.

    #86035

    Hi,

    Ohh.. I looked via Explorer, Opera, Chrome, Firefox and Safari on a Win 7 64bit machine and did not see that flicker and change in opacity of the text inside the slider as your video shows. So perhaps this is some strange iOS glitch.

    Kriesi I am certain knows more about iOS than I do, since I used an Apple computer but once in my life and gave up after I couldn’t find a way to turn it off.

    For now tho , Please look in your footer.php theme file to check if the following code is present there <?php wp_footer(); ?>

    Thanks,

    Nick

    #86036

    Yes I checked the code in footer.php, it’s there at the end where it says “the code should be placed just before the closing </body> tag” where it is as recommended.

    #86037

    Hey!

    My google chrome renders your page just fine, I can only see a short flicker in safari so you might want to try to add this experimental css rule which only works for safari and chrome:


    body {
    -webkit-font-smoothing: antialiased; Fix for webkit rendering
    }

    let us know if that helps

    #86038

    Wow, you are THE MAN, man. This fixed it instantly once added to the custom.css

    All looks crispy clear and refined again like it should be at least in the browsers you mention.

    The one thing that really bothered me was the flickering in Safari, that was really weird. Other browsers show the bloated version of the fonts which just isn’t that pretty but possible to live with :)

    Thank you guys a lot. Your support has been outstanding. Three thumbs up.

    Cheers.

    #86039

    Excellent! Glad Kriesi and Nick could help you! Let us know if you have any more questions.

    Regards,

    Mya

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Font therminal dosis looking more bold than before’ is closed to new replies.