Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #26907


    I was trying to give new typo to our, but for some reason font will not change. Originally, i was running on Open Sans, both, head and body styled vie Enfold -> Styling -> General. When i switch to any other combination, nothing happens, except when i use Web Safe Fonts for body.

    I have been through custom.css and quick css, but there is no font set. Any idea? I would love to add some spice with Coda & MAven Pro.

    Thanks, Sebastian.



    Go to includes > admin > register-admin-options.php, find this code:


    Add this code below, to register the Maven Pro font.

    'Maven Pro'=>'Maven Pro',

    You’ll be able to select it on Enfold > Styling > Heading Font.





    thanks, Ismael, now I can choose MAven Pro as Heading Font indeed, but it will not show up in the frontend. Maybe it depends on the fact, that I make heavy use of the Special Heading? Anyway, no matter which font i pick as heading, it does not appear on the page.

    As far as the body font i concerned, it only changes when i choose one of the Websafe Fonts, any Google font i choose (i would love to have my site shown with maven pro as body font) does not appear on the page.

    Thanks for your advice again,

    regards, Sebastian.


    Hi Sebastian,

    Right now you are loading in the Coda font as well as Open Sans but none others. Where are you setting the fonts exactly within the options?




    Hi Devin,

    thanks for coming back on my issue.

    I change fonts via dashboard-> enfold -> styling -> check if “Select a predefined color scheme” is propperly set (which i do never touch) -> go to tap “General” and change “Heading Font” to Coda, “Defines the Font for your body text” to Maven pro, hit “Save all changes” – but nothing seem to change in the frontend.

    Is this not the right way to change basic typo?

    Regards, Sebastian.


    I am having the same problem with open sans. Update to 1.8.4 and now font is different. Open Sans is selected in theme options but open sans is not showing up on the front end. thanks


    Installing the google fonts plugin, allowed me to return to open sans, but any ideas why the font changed?



    @mirzepapa: Please do this instead. Edit functions.php, find this code:

    global $avia_config;

    Below, add the add font filter.

    add_filter( 'avf_google_heading_font',  'avia_add_heading_font');
    function avia_add_heading_font($fonts)
    $fonts['Maven Pro'] = 'Maven Pro';
    return $fonts;

    add_filter( 'avf_google_content_font', 'avia_add_content_font');
    function avia_add_content_font($fonts)
    $fonts['Coda'] = 'Coda';
    return $fonts;

    On Enfold > Styling, select these two fonts.

    If you’re having problem with the Special Heading, add this code on your custom.css or Quick CSS:

    .av-special-heading h3 {
    font-family: 'Maven Pro', 'HelveticaNeue', 'Helvetica Neue', Helvetica, Arial, sans-serif;




    Hi Ismael,

    thank you so much, now at least the headings look like they are supposed to. But the content looks like some boring Arial still.

    Any idea for the final touch?




    okay, i have added to custom.css

    body {

    color: #444444;

    font: 13px/1.65em;

    font-family: ‘Maven Pro’, ‘HelveticaNeue’, ‘Helvetica Neue’, Helvetica, Arial, sans-serif;


    that did the trick for me.

    Not that elegant, but as long as it works, i am fine with this solution.

    Cheers, Sebastian



    The code seems to be ok for me. Maybe more efficient would be:

    font: 13px/1.65em, 'Maven Pro', 'HelveticaNeue', 'Helvetica Neue', Helvetica, Arial, sans-serif;



Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Fonts will not change’ is closed to new replies.