Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #23350

    I posted a plain text article using the Avia Layout Builder on one of my pages. I then highlighted some of the headings and assigned them <h3> tags. Then I saved the article and published it. All appeared fine. Then I noticed a small error in the article so I went to edit it and when I did, all the H3 tags had been stripped. I saved the article and published it again and sure enough none of the headings had been saved. I tried this several times and each time got the same result.

    If you look at the article now, you can see the headings, but that is because I have not been game to go back in again.

    http://websitedesign101.com.au/resources/articles/24-essential-pages-to-include-on-your-website/

    If it’s any help, I host the website with GoDaddy and used Internet Explorer to upload

    Your help would be greatly appreciated.

    Cheers

    Ivana

    #119469

    I am experiencing exactly the same problem as you are, Ivana. I’ve resorted to using Firefox only for editing purposes. That was fine, until recently, when Firefox started crashing on me whenever I tried to edit the slider on my homepage. But that is a different topic altogether.

    By the way: I am no techie, so please bear that in mind when proposing a solution :-)

    Elly

    #119470

    Same happens for me too…and also <p> </p> gets added all the time.

    #119471

    I don’t know that using firefox would help. I primarily use firefox and tags in the html editor get stripped and sometimes added all the time!

    #119472

    Hi,

    Yes, I reported the issue to Kriesi about the Advance Layout Editor. Elements goes blank when saved, stripped html tags etc. I’ll tag this thread to Kriesi.

    Regards,

    Ismael

    #119473

    I am glad that it’s a known problem. I thought I was going crazy! :)

    #119474

    Hi,

    I tried to replicate this issue on my install but I am unable to. I use Chrome (not sure how that matters), and everything saves fine. If you switch between the Advanced Layout Builder and Default Editor the text will disappear, but that can be solved by doing the following:

    Please look on line 45 of /config-templatebuilder/config.php and change it as per instructions found on lines 43-44 to take off the safety mode and deal with shortcodes only. Be Careful.

    Thanks,

    Nick

    #119475

    Hi Nick

    Thanks for your response. I have just tried doing the editing on Chrome and that worked perfectly well! Then I went back to edit the same article on Internet Explorer and the “h1″ “h2″ and “h3″ tags got stripped as soon as I went into the “Edit” mode.

    So it would appear IE and Firefox are the culprits, although I can’t explain why.

    I wonder if you are able to replicate the problem if you try editing using either IE or Firefox.

    Cheers

    Ivana

    #119476

    Hi,

    Yeh, I see it now. In IE10 I can replicate this.

    Here is a way to fix it (so far it did it for me). Please open up /includes/admin/register-plugins.php and add two forward slashes // on lines 22 and 24 so that they look like

    //require_once AVIA_PHP . '/class-tgm-plugin-activation.php';

    //add_action( 'tgmpa_register', 'avia_register_required_plugins' );

    That’s it. Please try pasting the text first into the Text view of the editor, and then switch to Visual view.

    Kriesi will surely have a proper patch for this in the upcoming updates.

    Thanks,

    Nick

    #119477

    Hey!

    This might be appearing because of a php memory error. If the next update doesnt solve your issue please let us know so we can check the site and your php memory ;)

    Cheers!

    Best regards,

    Kriesi

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Formatting gets stripped in Enfold’ is closed to new replies.