Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #17363

    Has anybody managed to get fotomoto working on their website? I have managed to get it working on the prettyphoto gallery popups, but I am trying to get the buttons onto images on the actual portfolio pages as well (so people don’t have to open up the prettyphoto gallery to buy the picture).

    does the support team have a solution for this?

    #95204

    Hi,

    I’ve never used fotomoto yet. Perhaps someone else knows about it.

    Thanks,

    Nick

    #95205

    Is there a way to disable the prettyphoto plugin, or control which pages it should be used and which pages shouldn’t.

    The issue is that in my portfolio, I was told to disable my prettyphoto plugin (for fotomoto to work on the page).

    #95206

    i found another post in here which said to told me to remove the following in avia.js:

    //activates the prettyphoto lightbox

    if(jQuery.fn.avia_activate_lightbox)

    jQuery(‘body’).avia_activate_lightbox();

    but this is not doing the trick. It removes the overlay pop-up frame, but the image still pops up over the existing page. There must be something else I need to deactivate?

    #95207

    Actually it is possible to remove all links from your images. Open up sentence/js/avia.js and replace following line at the very top:

    jQuery(document).ready(function(){

    with:

    jQuery(document).ready(function(){
    jQuery('.slideshow a').find('img').unwrap();

    This will remove the link from the slideshow images.

    #95208

    Ok… So far so good. This enables the fotomoto buttons on the portfolio now *yay!

    but it removes the image as a clickable button on the portfolio page (we have to click on the text to enter the portfolio) :(

    any chance to make that clickable ?

    http://photography.kevintrinh.com/

    #95209

    Hi Dude… just realised that code you gave it only works on Firefox and not on Chrome, or IE

    #95210

    1. Ok… got the code working (deactivating prettyphoto plugin) on Firefox, chrome & safari… but not on IE.

    2. Still can’t make the images clickable in the portfolio page :(

    #95211

    Hi!

    Try following code instead – this will solve issue 2)

    jQuery(document).ready(function(){
    if(jQuery('.template-portfolio-overview').length < 1){
    jQuery('.slideshow a').find('img').unwrap();
    }

    Best regards,

    Peter

    #95212

    sorry… didn’t work :(

    #95213

    Hey!

    I adjusted the code – please try it again.

    Best regards,

    Peter

    #95214

    spot on. Thanks peter.

    Please let me know if you are able to come up with a solution on IE (deactivating prettyphoto in IE).

    #95215

    hummm, i’ve just uploaded a couple of new photos, and opened the website up in safari. In the portfolio page (http://photography.kevintrinh.com/portfolio-item/birdwomen/) on first load up and mouse over the image it displays the dots, and left-right arrows (thinking that it is a slide show when its not). I have to press shift+reload mouse click (fresh reload) then it loads properly (the fotomoto buttons appear below).

    Could there be another area where we need to disable it for IE and Safari? Currently having as it is cuts half my audience because majority uses IE and safari on the ipad, iphone :(

    #95216

    Hey!

    No, but it seems like these browsers are a bit buggy when it comes to the unwrap() jquery function. However I’m not aware of an (easy) alt. solution.

    Regards,

    Peter

    #95217

    all good. thanks anyway peter.

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘fotomoto’ is closed to new replies.