Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #18395

    website: http://redrachelcreative.com/

    I’m afraid I may have seriously messed up my site. Originally I had home, portfolio, about, and contact pages. I decided I wanted to just make my portfolio page my home page. So I deleted my home page and switched the theme settings to have the front page display the portfolio page. It works when I am logged into my dashboard but when logged out I receive a 404 error for the home page of my site.

    I’ve tried switching my theme setting for front page to the contact page as well. The 404 error page is still displayed for the home page.

    Any help to get my home page back up is very, very appreciated. Thanks!

    #99299

    Hi englerae,

    A couple things you can try: Go to WordPress Settings>Reading and make sure the option for the home page is not set to static.

    Next, try changing your permalink settings in Setting>Permalinks to the default value and then saving. Save it 2 more times and then check the home page again. If it works, try changing it back and saving again.

    In your Pages section of WordPress go to the Trash. Delete the Home page file that you deleted earlier.

    In your Theme Options>Portfolio make sure you don’t have any portfolio options that have no page chosen to be displayed on. If there is one, just delete that option group by hitting the red X and then save all options.

    Regards,

    Devin

    #99300

    Thanks so much, Devin!

    I checked under Setting>Reading and I noticed for the static page setting I had not selected what page I wanted to display. I set it to my portfolio page. (right now I need a static page as I do not have a blog) I also went to pages and permanently deleted any pages in my trash.

    Checked my site and it works! yay!!!

    thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Front page does not display!!! Getting 404 error for home page.’ is closed to new replies.